0

I am using English language in Chrome and have this language set as default for most of the sites, but since I am from Poland I have forced (in Google Account settings) to have all the search results and accompanying data to be strictly shown in Poland.

This is true (I see results from Poland as first and in Polish), but for some reason for past few days Google started to show values with English (United States?) locale settings, i.e.:

  • I see street number as first (we have it after street name in Poland),
  • I see dates (month names specifically) in English etc.

enter image description here

(the above should be: Adres: Juliana Zubrzyckiego 38 and Odwiedzone: kwiecień)

I don't know what happened (AFAIK I haven't changed anything in my Google Account settings for at least months) and how to change it back (so dates, addresses etc. are shown in Polish locale)?

1

I don't know what happened (AFAIK I haven't changed anything in my Google Account settings for at least months)...

Google updates it's algorithms every few months and it seems that the latest updates have caused quite a few issues.

There is a number of them mentioned under the official support community

Google search uses German, when I have English set as my language, as well as Poland set as my location

the Romanian pages have been replaced in Google's results with English pages.

Is something wrong on my end or is this an issue with google search?

and so on...

as well as in Google Search itself.

There are also issues with images search, where "show sizes" option is nowhere to be found.

show sizes

As you can tell, issues like this emerge again and again and do not have a fixed solution.
You can always contribute by reporting them to Google.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.