1

I am trying to import the whole table from this site into a Google Sheet, but I keep getting the imported content empty error.

I realize this error is very common and I have done my fair share of research on this site before posting. Here's what I've tried so far:

  1. https://webapps.stackexchange.com/a/97588
    This answer addressed the same topic as my question but did not focus on how to grab the whole table, only a specific element from within that table.

  2. https://webapps.stackexchange.com/a/97615
    I also tried to go here, understanding that the solution probably has something to do with the source code maybe not including the proper tags in the HTML. I tried the suggested solution and played around with it for a solid hour but to no avail.

  3. https://webapps.stackexchange.com/a/78864
    Finally, I tried this post thinking that the solution may have something to do with the fact that the site might update dynamically. So I also played around with the solution in that post, but alas to no avail.

Please be gentle with your responses, I am new here. But I am always willing to pick myself up and keep trying.

2
  • Welcome. Great work doing your “homework” but the question is too broad for this site. I suggest to focus it on using IMPORTXML or using Google Apps Script, maybe posting a question for each one but not to ask about both on the same question.
    – Rubén
    Sep 13 '19 at 12:04
  • Thank you Ruben, will do! Sep 14 '19 at 0:10
1

I don't think you can use importxml in this scenario because this website is built with Vue.js

Vue.js is a JavaScript front end framework

Your best shot is to Right clic > Inspect Element
Then Right clic on the table element > Edit as HTML.

Now just Copy > Paste and exploit the data.

1
  • 1
    The related limitation isn't limited to Vue.js, it applies to any case where the data is added dynamically.
    – Rubén
    Sep 13 '19 at 13:50

Not the answer you're looking for? Browse other questions tagged or ask your own question.