1

In any browser I open, gmail has this annoying "feature" that previews pdf files (I haven't tested other files) in google docs viewer. This is inconvenient because when I try to print, it opens a new tab and I have to hit print again to open the print menu.

Does anyone know how to disable the Docs Viewer so that I click on a document it opens in a new tab in one click?

Otherwise, is there a way to view the document in the Docs Viewer and access the print menu straight away, skipping the new tab in the first place?

Browser is Google Chrome Version 77.0.3865.90 64bit. The OS is Win 10

3
  • What's your browser/os? I can't reproduce your problem, for me the print menu opens up automatically in the new tab when I press print in the docs viewer. Sep 28, 2019 at 11:53
  • Browser is Google Chrome Version 77.0.3865.90 64bit. The OS is Win 10 Oct 3, 2019 at 11:59
  • This question has been bumped by Community user 14 times. I’m voting to close this question because troubleshooting-like questions are off-topic in Web Applications SE. Also the context might no longer be reproducible. Nov 7, 2023 at 18:55

2 Answers 2

0

When I click on the "print" icon in the docs viewer it opens a new tab with the print menu already pulled up, see screenshots below. I'm using Google Chrome on a Macbook.

Clicking on the print icon boxed in red:

enter image description here

Opens the print menu in a new tab: enter image description here

To disable docs viewer, you can try this old workaround: https://superuser.com/questions/219113/stop-chrome-from-opening-pdfs-in-google-docs-viewer

Or try this: https://superuser.com/questions/724203/how-to-automatically-open-saved-pdfs-in-system-viewer-on-chrome?rq=1

1
  • Mine does not open the print menu already pulled up like that. It opens a new tab with just the PDF open, and I can hit print from there to open up the print menu. I just don't feel like it makes sense that i have to hit print in two different pages to print something. It isn't the end of the world, but i feel like it is an option that I am just not seeing Oct 2, 2019 at 11:59
-2

Settings might have too be change (Google is famous for opening other tabs) I suggest locating the primary settings for the browser and make sure unwanted or pop up pages are disabled. Then see your settings for Google docs and repeat the above process. If the problem still pressits try to unfortunately use other programs like adobe or just print. <<<make sure you disabled google docs or other programs to just print

Not the answer you're looking for? Browse other questions tagged or ask your own question.