17

After an update, Slack now formats messages as you type them which is highly disruptive to how I type. How can I disable this feature and only show message formatting after I hit send?

1
  • 1
    I sure did like seeing the Markdown format. This should be an option.
    – ale
    Commented Nov 27, 2019 at 14:09

2 Answers 2

10

Go to Preferences -> Advanced -> Input Options and enable Format messages with markup.

3
  • This should be marked as the right answer.
    – Jai Pandya
    Commented Aug 31, 2020 at 17:30
  • 1
    This also disables formatted text from pasting, which is what I was after.
    – Tiffany
    Commented Apr 27, 2021 at 13:03
  • It also allows you to paste plain with no formatting on mac "Option+Shift+Command+V” - It was so frustrating. Commented Mar 6, 2022 at 23:27
0

Slack only recognizes as markdown if you actually type the special character such as ` in Slack. Pasting something with it in it such as: this is only a test will not be formatted as code, since typing the ` is the trigger.

So perhaps open a notepad, type what you want, and then copy/paste it into Slack?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.