6

I want to disable this very annoying youtube autoplay feature on my web browser. I try to disable it using youtube UI but after some time it turns on and autoplay starts working again! I am using Firefox 70 on Ubuntu. The answer from 2015 on this site doesn't seem to work for me.

1
  • There is a toggle above the "play next" list on the right.
    – Burgi
    Nov 27, 2019 at 9:18

4 Answers 4

1

On the left of your playing video there is a list of videos that will be played next. At the top there of that list there is a toggle switch to enable or disable autoplay.

This image shows the switch in disabled mode:

enter image description here

5
  • 1
    "I try to disable it using youtube UI but after some time it turns on and autoplay starts working again! I am using Firefox 70 on Ubuntu."
    – reflex0810
    Nov 28, 2019 at 14:27
  • It is a cookie maintained option. Do you clear your cookies regularly?
    – Burgi
    Nov 28, 2019 at 15:01
  • 2
    no, but i want to maintain autoplay disabled even after clearing cookies?
    – reflex0810
    Nov 29, 2019 at 13:28
  • That is not possible I am afraid.
    – Burgi
    Nov 29, 2019 at 23:08
  • I believe this is possible with some javascript magic. I just can't figure out what exactly to do and need an advice.
    – reflex0810
    Jan 4, 2020 at 13:58
1

I'm with you, I can't stand this feature. I don't log in to Youtube and I browse in private mode so autoplay is enabled every time I close the browser.

I wrote a userscript that checks if autoplay is enabled every 10 seconds, and disables it if so:

https://openuserjs.org/scripts/thomper/Disable_Youtube_autoplay

The usual applies: no warranty, have only tested it on Firefox with TamperMonkey (Works On My Machine™), etc.

Though if it doesn't work for you, you can open an issue on OpenUserJS and I might have time to look into it.

0

I started having this issue since yesterday, I had to download and extension. I have no idea why Youtube autoplay is checked by default.

0

This seems to require an extension now. The current UI for YouTube has the auto-play toggle built into to player. It is always on by default each time you go to the site after having left. After several tries I found "Disable YouTube Auto Play" which still works and doesn't try to do anything else. I am not linking because google may very well break things again in the future.

3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.