2

I have the following Gmail filter:

Matches: to:(marketing.emails@mail.com)
Do this: Skip Inbox, Mark as read, Apply label "marketing.emails@mail.com", Never mark it as important

The filter marks the messages as read, but it doesn't archive the emails. They remain in my inbox.

If I open the filter, it finds the emails in my inbox. If I check "Also apply the filter to matching conversations", the matching emails in my inbox are successfully archived. But future emails don't get archived. This is the issue - I don't want to manually apply the filter everyday.


A similar question is asked here. The answers are to go to Settings→Inbox→Filtered Mail and unchecking the option: "Override filters - Include important messages in the inbox that may have been filtered out."

I have already unchecked this option and the issue remains, so please don't suggest this solution.


Note - This filter is applied to emails that are received through Gmailify. Since the "Mark as read" portion of the filter works, I don't know if this is a relevant detail.

0

Assuming the filter rules themselves are correct, on the next screen these options are critical, specifically:

Skip the Inbox (Archive it)

Never send it to Spam

Never mark it as important

Users may also be interested in the other two checked boxes:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.