For some reason a subset of my Google Contacts are being moved from the My Contacts list to the Other Contacts list. Unfortunately this has the effect of removing them from my iPhone as I have them synced, and only the My Contacts list is synced. It has happened three or four times in the last few months. It affects about 50 of my 160 contacts.

It seems to happen after I make minor changes to contacts on my phone - last night I added a number to a single contact, and today I noticed that the contacts were missing.

Any ideas on what is causing this and how to fix it?

  • @RishabhPoddar I'm not sure what happened but I meant to mark my own answer as the accepted answer, not yours. While useful information your answer did not fix the problem.
    – jwaddell
    May 6, 2012 at 22:39
  • I have had this problem. I've noticed that the contacts being moved from 'My contacts' to 'Other contacts' are those with an empty email address field.
    – user88057
    Feb 20, 2015 at 21:03

4 Answers 4


In GMail Contacts:

My Contact List Contains:

  1. The contacts that you have manually added to GMail using the GMail interface.

Other Contact List Contains:

  1. Email address that got automatically added because you have sent them email(s).

  2. Email address that were uploaded to your GMail account in the form of a .csv file.

  3. Email address that were uploaded to your GMail account because of using sync feature with your phone.


I fixed this by removing all my mail and contact accounts from the phone (note - not deleting the actual mail and contact items, just removing the sync accounts) and then adding them again. I guess something must have become corrupted somehow.

  • you should post this as a comment not answer.
    – user19533
    May 6, 2012 at 7:43
  • Well deleting everything is an extreme way. Did you add them again through your iPhone contacts Sync or through the GMail interface?
    – user19533
    May 7, 2012 at 4:53
  • I just deleted the accounts, not the addresses themselves. I just had to add the accounts again to the phone to get all my contacts back. I'll update the answer to make this more clear.
    – jwaddell
    May 7, 2012 at 22:38
  • Have you found a solution for this yet? I'm having the same problem. Whenever I delete a contact on the iPhone, Google Contacts moves it from "My Contacts" to "Other Contacts", instead of just deleting it like the iPhone does. I tried what you said, by turning off the contacts sync on iPhone, and then turning it back on, but it is still doing it. Thanks
    – user23167
    Aug 10, 2012 at 10:15
  • @N.T. I completely deleted all accounts from my phone and then re-added them, and the problem hasn't happened since.
    – jwaddell
    Aug 14, 2012 at 4:17

Select the contacts you want to remove from "My Contacts", go to the pull down menu "Groups" and un-check the "My Contacts" box. Be sure to apply the changes at the bottom of the pulldown. They should be moved to the "Other Contacts" section.

-- Found the answer in Google's Product Forum: How do I move contacts from "my contacts" to "other Contacts"?


I had the same symptoms. It is problem on android platform as well. I think one of the contact cleaning or duplicate finder app maid this error (maybe google synch..?). It moved many of my contacts to "other contact" especially my contacts with the name containing: '.' . I use . in the name to group them. i.e. salsa.somebody, or compname.somebodyelse. Or somebody's.relative_names. So many of my such contacts were moved and disappeared from my phone contacts.

When I wanted to find any of the moved contact in my phone's contact list I was not able. (I enabled all type of contacts to show on the phone). However when myself I typed the number or they called I sow the name of the contact. Therefore I checked on contacts.google.com and sow all my missed contacts under "other contacts" group. If you have the same, you can click to "add to contact" and it will move back to the right place and immediately synch the information to your phone. You cannot make mass update on the new google contacts. So you need to look up one by one and make the change. The old one works fine, you can select all your contacts under other contacts and move them once. For me this link worked to access to the old UI: https://mail.google.com/mail/u/0/?hl=en&shva=1#contacts/group/26ae/Other+Contacts (I'm not sure how long this is supported)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.