1

On this page - https://translate.google.com/ - I see the serbian cyrilic language as the interface language, probably because my IP address is in Serbia at the moment.

I want this page to always be in English, regardless where I actually am.

Is it possible and how?

By the way Chrome is set in English and this works, but especially the above page is on serbian cyrilic.

  • Are you logged in to Google? For me, it always remembers the last used translation languages. (?) – MrWhite Dec 27 '19 at 23:05
  • 1
    Yes, I'm logged in. It's not problem with translation language but with user interface language – qadenza Dec 28 '19 at 7:09
  • Ah, sorry, missed that! – MrWhite Dec 28 '19 at 10:54
1

It seems you can set/override the interface language by specifying the appropriate IETF language code in the hl URL parameter.

So, for English, this would be:

https://translate.google.com/?hl=en

(For Serbian cyrillic language you would use sr-Cyrl.)

  • that's it, solved. But still strange, isn't it? Default language should be english if not specified (https://translate.google.com) – qadenza Dec 28 '19 at 17:52
  • I would agree. I don't think the language should default based on the IP address (apart from being potentially inaccurate as a location indicator, location is not necessarily an indicator of language anyway). If anything, it should default based on the value of the Accept-Language HTTP request header - what is your browser reporting for this? (It's possible that both Serbian Cyrillic and English are "accepted", but Serbian Cyrillic has a higher priority?) – MrWhite Dec 28 '19 at 18:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.