1

When I try to setup a Custom URL for a new google sites it says "Custom URL already taken"

Sites "Add custom URL" dialog

Looking at Company Profile, Custom URLs There is no custom URLs set.

enter image description here

Where else can I look to find and release the taken www?

1 Answer 1

3

Find what service is currently using www

Connect to ghs.googlehosted.com using your domain name. There are several options, choose one of them.

  • Configure your DNS for the www with CNAME to ghs.googlehosted.com
  • Add 172.217.21.179 www.example.com to your /etc/hosts
  • Check the response directly: curl -v http://ghs.googelhosted.com -H "Host: www.example.com"

In my case the returning site was blogger.

Blogger is not part of the GSuite core services and in my GSuite-account it was disabled. Enable the blogger service won't help as there is no interface in the admin panel to disable the custom URL.

Solution

Although Google-sites custom URL refuse to use www others don't complain.

  1. Go to the Company Custom URL page
  2. Pick any service and set www as it's custom URL.
  3. Save and confirm that you have made the changes in DNS(even though you haven't)
  4. Change it back, remove www from that service.
  5. Save and confirm again.

Explanation: When there is a lingering reserved custom URL of www pointing to blogger, step 3 will overwrite it. Step 5 will then free it. You can review the progress by applying the top troubleshooting steps as you apply the changes.

In step 1 ghs.googlehosted.com will still serve blogger. After step 3 it will serve a redirect to the service you picked. After step 5 it will show a simple 404 page. This is how you know you have successfully freed the Custom URL www. Google Hosted 404 page

Configure Custom URL

Now you can go to the custom URL panel and successfully use the www subdomain for your google sites.

4
  • 2
    Thanks, worked for me.
    – bers
    Aug 28, 2020 at 8:58
  • @hultqvist, I have the same issue and have spend hours with Google who can't figure this out. I tried adding and deleting a custom URL for another service, but it won't let me add. I'm unclear on your instructions for finding out what service is using this custom URL. I haven't set up this domain AFAIK in the past so I can't imagine where the URL would be used.
    – myklbykl
    Jul 17, 2021 at 15:56
  • @myklbykl I never used blogger either. The three bullets represent three different methods to achieve the same thing. The third option is quickest if you have access to a terminal with curl. The first option is probably more familiar as you would configure CNAME during the website setup.
    – hultqvist
    Jul 18, 2021 at 10:47
  • @hultqvist — thank you for the feedback. The first time I tried the curl option I got an error because there's a typo in your example above and I just copy and pasted it. Now I'm not sure how to read the results as they don't seem to tell me anything other than "Server: ESF". I've been trying for weeks to have Google figure out the problem and they can't. The Admin console also won't allow me to set any of the other services (like mail, e.g.) to www, so that workaround isn't fixing it unfortunately.
    – myklbykl
    Jul 20, 2021 at 17:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.