When I send event invitations through Google Calendar, there is one person listed that does not receive the invitation. All others in the list receive it.

He is on gMail too and has checked his spam folder. Other emails from me he receives ok. Is there some other setting he needs to change to receive the invitations?

  • does he has a google Calender account? – user19533 May 4 '12 at 10:59
  • I believe so. But regardless he should still receive the email with the calendar request in it. – sickgemini May 10 '12 at 23:34

This is likely because of he has explicitly denied sending notifications about events to him.

Ask the guest to make sure that they didn't turn off email notifications for new events. If they use Google Calendar, ask the guest to check their email notifications while on a computer.


To change this setting:

  1. Open calendar (you can't do this from mobile apps!)
  2. Click on gear/cog and choose settings
  3. On the left side under Settings for my calendars select the calendar for which invite was targeted.
  4. Scroll down to General notifications and enable new events notifications

Screen capture of the General notifications section in the calendar settings

  • This answer is a little stale now. I could not find "how you would like to be notified" in the settings. It's probably been changed. – jcollum Feb 15 '18 at 21:08
  • 3
    @jcollum updated answer, maybe that helps – Timo Feb 16 '18 at 4:48
  • 1
    Once you are in Calendar Settings you have to click on the calendar name to see the notifications options. – Cecily Crout Feb 20 '18 at 16:36

protected by Community Jul 3 '18 at 19:37

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.