I made a combo chart where the x-axis is the date field. I have gaps in the date, but want my chart to reflect the gap. For example, I have big gaps in April, May, June, August, September, and October.


How do I show the x-axis with missing date ranges without altering the data? The data is being imported from a CSV elsewhere which I can not change, only read in.

Edit add:

I am using combo chart

My horizontal axis options look like this:

horizontal axis

2 Answers 2


Unfortunately the Combo Chart doesn't support the Treat labels as text for the horizontal axis. The alternative is to use a different chart type like:

  • Area chart
  • Column chart
  • Line chart

and maybe others

First change the chart type to one that supports the required setting, then uncheck the Treat labels as text checkbox

One way to do this

  1. Open the chart editor
  2. One the Setup tab, change the Chart type to one of the chart types mentioned above
  3. Click the Customize tab
  4. Click the Horizontal axis title to expand it
  5. Uncheck the Treat labels as text checkbox


  • I don't see that option in horizontal access. Does it depend on the data type of the column? Or that I have a combo chart?
    – Sun
    Commented Mar 4, 2020 at 23:44
  • @sun Apparently you don't see this setting because you are using a Combo chart. Commented Mar 5, 2020 at 0:07

I found the same option that Rubén described but in a different place.

It was in the main chart setup page. Surely enough, unchecking Treat labels as text fixed it!

Note that this is a simple Stacked column chart and not a Combo chart.

Screenshot of the setup page

  • +1 Thank you. I believe combo chart options differ and that unfortunately is not an option. But good find, useful for other situations!
    – Sun
    Commented Dec 19, 2021 at 18:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.