1

I tried this tutorial, but it was not written for v8-- and the logger and javascript parameter passing between html and the script doesn't work. https://www.youtube.com/watch?v=RRQvySxaCW0 Is there any way to make this code work in v8, too?

Is there any way to make the logger work so I can see the parameters being passed in the URL to the script? I use this at the end of the web app URL ?name=Joe&age=23 and I see nothing in Logger.log's transcript.

3
  • Welcome. Questions on this site should be about something specific regarding how to use an specific web application. Question that solely asks for external resources like tutorials are off-topic. Please checkout How to Ask and help center. Mar 29, 2020 at 19:34
  • Thanks, I reworded the question to ask about this tutorial
    – anjchang
    Mar 31, 2020 at 0:18
  • Questions on this site should include only one question per post. Please post a new question for the second part. Mar 31, 2020 at 1:15

1 Answer 1

1

Update

The Chrome V8 runtime has become the default Google Apps Script runtime for new projects. The Old runtime, Rhino, is still working, but some features, like the online debugger, might throw errors if the code isn't compatible with V8. Ref. https://developers.google.com/apps-script/docs/release-notes#April_13_2022.

Also, the legacy Google Apps Script IDE is no longer available. To disable the Chrome V8 Runtime, go to Settings and uncheck the corresponding option.

Google Apps Script IDE Settings


Original answer

Note: This section was slightly edited to enclose the obsolete part between <obsolete> and </obsolete>.

First, you should know that using V8 in Google Apps Script is optional.

<obsolete>

If you aren't ready to use it, on the menu bar, click Run then Disable new Apps Script runtime powered by Chrome V8

If by Logger you mean an statement like Logger.log(JSON.stringify(e.paremeters)), if you disable V8, after running a function you could see the logs logged by Logger by clicking View on the menu toolbar then Logs

\</obsolete>

1
  • Thanks @Rubén. Now I can now see the URL go to the script. but I still get "undefined clicked" instead of the actual username for the second part of the tutorial.
    – anjchang
    Mar 31, 2020 at 3:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.