3

Starting this morning, while using Gmail as usual, e-mails sent through one of my accounts started to generate return-errors:

enter image description here

This started to be happening today (after 2-3 years of using this account without any problems) and only when sending e-mail through this account (I have three others configured in "Send mail as" functionality and all of them are working normally).

In accounts settings, in Gmail, I have noticed that this particular account is the only one that I am still accessing (sending e-mails) using TLS instead of SSL (recommended by Gmail). I tried to switch to SSL, but I am getting the same error for both SSL and TLS:

TLS Negotiation failed, the certificate doesn't match the host., code: 0

enter image description here

The biggest concern here for me is -- why am I getting TLS-related errors ("TLS negotiation failed"), if I am attempting to connect over SSL?

enter image description here

What is the actual cause for this error? Is this really a problem with configuration on my side (i.e. in Gmail), as first message suggests? Or is this a server-side related problem, as second and third images shows?

Is there anything that I can do? Or all the work is on server administrator side?

0

The below solution is specifically for GoDaddy users only, but should work on every other hosting. Of course, with changed steps, fields names, sections etc.

In general this solution is based on the fact that you should use (in account settings of your Gmail) an exact server URL that is assigned to your mailbox. Not the general server URL / just the domain that you were using so far.

This means that:

  1. If you know the exact server URL of your mailbox at your hosting then you can skip five first steps below and just paste the host name to Gmail settings Accounts.

  2. If you don't have access to your domain configuration and don't know the exact server's URL that your mailbox is using then you must contact your system administrator or support and get this information from that source.

The example steps of getting account's server URL in GoDaddy (try to do similar at your hosting):

  1. Login to your GoDaddy account
  2. Select All Products and Services
  3. Click Manage in Web hosting section
  4. Click cPanel Admin
  5. Copy the shared server host name from the cPanel URL. Host name is between https:// and :2083/ so in this example case the correct host name would be n3plcpnl0082.prod.ams3.secureserver.net
  6. Paste the host name to Gmail settings Accounts and Import/Send mail as/edit info/SMTP Server and click Save Changes

enter image description here

Gmail has changed the way how they check SSL certificates, so the described situation is a failure on both your hosting and Gmail side.

Here is source of this solution along with some extra screenshots if needed. I didn't add these screenshots here because they depict GoDaddy's solution, not the general one.

2
  • 1
    Welcome to Web Applications! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference.
    – Glorfindel
    May 21 '20 at 6:57
  • I have created an answer being nearly exact copy of the linked forum post, by Gaurav. So the above comments and downvotes may be retracted, I think.
    – trejder
    May 22 '20 at 8:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.