I would like to know how I can disable the email suggestions in Google Docs comments.

Whenever you write a comment on a Google Doc and start typing with @ it will suggest, and sometimes auto-complete, email addresses. This happens no matter if the @ is standalone or in the middle of some comment text. Example of what is meant:

Example of @address

I'm not sure where these addresses come from, but they are useless to me and annoying when auto-completing while typing. I could not find such a setting in docs preferences, nor when searching for it.

I would be fine to install a Firefox extension if needed to get rid of them.

1 Answer 1


Updated answer

It looks like this is a bug in Google Docs.

To report it as a bug please go to Tools >> Help >> Report a problem and follow the steps on the pop up to send a message to Google.

How to report a bug to Google 2020

Original answer

You need to disable it under Tools >> Preferences

Step 1

enter image description here

Step 2

enter image description here

  • Please remember that as per site guidelines when an answer addresses your question, accept it and even upvote it so others can benefit as well. Apr 27, 2020 at 9:55
  • Thank you for this suggestion, however I already have this option disabled and the suggestions are still showing up. It happens on any doc, no matter in which folder. I have made a public new doc file here for you to see, with the setting you have suggested, in case that helps: docs.google.com/document/d/…
    – Cassidy
    Apr 28, 2020 at 15:24
  • I have upvoted your answer since it might be helpful to others, but the vote probably isn't showing due to my low reputation. If there is no other fix to my ongoing problem I can also mark it as the solution, even though it didn't fix it for me.
    – Cassidy
    Apr 28, 2020 at 15:49
  • It looks like you are right. (used to work). I have updated my answer. BTY your upvote is somehow lost. Apr 30, 2020 at 2:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.