3

To change a spreadsheets locale one selects File > Spreadsheet Settings > Locale

There is a problem here in that one must make that change for each new spreadsheet created and not doing so causes some difficulties in that cells need to be changed to the new Locale which isn't always successful.

How does one set the default locale for every new spreedsheet in Google Sheets?

2 Answers 2

4

The locale setting is set by the language setting for your account. You can set/change this at: https://myaccount.google.com/language

The timezone is a device setting.

Summarised (and confirmed) from a Google Support question Set default timezone/locale for all current and future Sheets

2
  • ah yes! that's the one! It was already set to English UK but I needed to just set it again - a little popup at the bottom, possibly easily missed, said 'not all apps are set to UK, would you like to change them all?'
    – atreeon
    May 6, 2020 at 13:00
  • If this is the official solution from google it's a huge design flaw. I'm Argentinian, I use the d/m/y format, but I've used software in english from the past 35 years since I got my first Commodore 64. The interface language is not the locale. If I want to use the correct locale for date format, I have to choose Spanish for the user interface, which is not what I want. If I want to use the english language for the locale, I'm stuck to whatever date format is used in what google regards as english speaking countries.
    – Petruza
    Oct 2, 2020 at 12:04
2

I had this issue and found a solution. This should also update any new Google Sheets that you create.

Instructions below:

  • Open a new Google Sheet
  • Click on File
  • Click on Spreadsheet Settings
  • Click on Display language, This is at the very bottom left of the interface window.
  • Click on the Pencil next to the language
  • Start typing English into the search bar
  • Click on English
  • Click on Australia
  • Click on Select
  • Then Click on Save Settings

Note that it will not update the new sheet in which you made the change but it will for all new sheets created.

enter image description here enter image description here enter image description here enter image description here enter image description here enter image description here

1
  • Tried this and it does not work for me. Still seeing "Locale: United Kingdom" and "Time Zone: nothing" when creating new sheets. Mar 20 at 7:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.