In one of our Confluence team spaces, we are consistently experiencing the problem of content not rendering (despite us having access to space)

enter image description here

More specifically, symptoms are as follows

  • Most other spaces work just fine; thus far we've find the problem to be isolated to just one particular space
  • Within the affected space, some pages still render fine. But majority show this message

One thing to point out, we've found this impacted space to take slightly longer than usual to load on browser (longer than what other spaces take, that is)

Hereby re-iterating that we've checked that users have proper accesses (read / edit) to the space

What we've tried

What could be wrong here?


So the other day, we discovered this strange hack that worked

That's it! This fixes the problem

But it is hardly ideal since we have to persistently keep an Incognito Window running for this sole purpose

1 Answer 1


Ad-blocker to blame

Failed experimentation with clearing cookies made me forget another fundamental difference of Chrome's Incognito mode (vs normal window)

By default, all extensions are disabled on incognito (unless explicitly enabled by user)

Just whitelisting my_org.confluence.net on AdBlock resolved the issue

enter image description here

The support pages do mention some issues with adblockers

Credits to @GautamSahni for this finding

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.