0

When I make a search on Google, the results are sometimes in my native language and the websites listed are from my country. That being even if my query is in English. At the bottom of the page, I can read my location, which means Google is tracking me somehow, and I want it to stop. I've tried to search about it, but all I get is something indicating me to change settings in my Google Account, but the weird thing is this is happening even in 'Incognito mode'. What's even more weird is the fact that sometimes, the results are in English, sometimes in Portuguese (my language).

So, how to effectively stop Google from tracking me? The solution I have right now is using DuckDuckGo when I want to see the results in English when Google shows the results in Portuguese. But I'm not quite satisfied as this is not really a solution.

  • 1
    Does this answer your question? How do I make Google default English in Chrome? – Rubén Jun 26 at 19:08
  • @Rubén Not really. When I use google.com/ncr, it redirects me to google.com and then the results are still in my language. The solutions mentioned in that question are all from 6+ years ago, so I suspect they are outdated and don't work out anymore. – Enzo Nakamura Jun 28 at 2:01
0

I found a solution. Just went to search settings and changed "Region settings". I just find it weird that I've seen no places mentioning it.

| improve this answer | |
0

You can control location permissions for individual sites. I am using firefox and it is working for me. After opening the website click on lock icon(located just before https), click on right arrow mark and then more information. There you can see permission tab where you can control permissions. You can refer following screen shot. Screen shot

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.