How do I prevent the Google Calendar App from sending me a daily notification about my events for the day? There is no setting provided to do this. My choices seem to be either not to have any Google Calendar integration at all, or for everyone who has it to receive an irritating daily notification.

(In fact, how do I prevent notifications from apps generally. It seems many — all? — apps cannot be silenced.)

How do I disable daily notifications from Google Calendar App in Slack?

2 Answers 2


Write /gcal settings (In slackbot or another thread) and you can configure it there


It sounds like you've got two issues. One is broadcasting to everyone and second is receiving the 'there are no events today' notice.

To only broadcast to yourself, in the integration setup choose your personal channel as the 'what channel to post to' destination. Within the Slack channel you post to, you can then choose your notification preferences and mute it if desired.

In some cases you can introduce a 'there are no events today' message. To work around this, first use a calendar that only contains the events you want posted. With this calendar, choose to post Event Reminders 'at the start of' an event instead of a daily summary.

Some of these options may only be available in the Google Calendar for Team Events for Slack https://slack.com/help/articles/360047938054-Google-Calendar-for-Team-Events-for-Slack and not in the Google Calendar for Slack.

post events vs empty summariespost to your personal channel

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.