0

English isn't my mother tongue and not a main language where I live either. But I have a certificate for C1 level english. So I added English to my spoken languages in my google account and even switched some services like Youtube over to English, tried to disable translation for english etc... However, Google still realizes I am in a non-english speaking country and keeps bothering me with stuff like:

  • Auto enabling english subs on mobile youtube
  • Randomly and terribly auto translating titles in youtube on desktop and mobile
  • on Chrome Mobile constantly asking me if I want to translate english texts

How can I tell google that I would like to read english texts in english for good and that it shan't ever bother me again about it in all of their services?

0

You can try to change the language setting of your browser and set it to English I think it will avoid this problem.

| improve this answer | |
  • This won't fix it for stuff like the youtube app. Is there no google-account-wide way to disable translation for specified languages? This seems like something they'd have somewhere.. – jaaq Jul 24 at 8:09
-1

Are you on chrome? if so then go here https://myaccount.google.com/language and change the language.

| improve this answer | |
  • I did. English is my main language there. – jaaq Jul 23 at 10:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.