Every time I delete a row in a certain worksheet in a Google Sheets spreadsheet, I get the following error:

Can't sync your changes. Please copy your recent edits, then revert your changes.

This occurs in Chrome, Safari, and Firefox, so it's clear that all "fix the browser" type solutions (for example, see here or here) aren't applicable.

This error seems to occur when you hit the 1.02 million character limit (see here), but the total number of characters in my spreadsheet is only 25,468, so that doesn't seem to be the issue for me.

One user encountered this issue with respect to protected ranges (see here) and was able to levy that for a solution. However, this sheet has no protected ranges. For good measure, I also made a copy and removed all users but myself (as owner), and the issue persisted.

One user got around this by opening up the same sheet in a new tab while the error message was up in another (see here), but that did nothing for me.

It seems there may be a workaround by exporting to Excel and then reimporting into Google Sheets (see here), but as this spreadsheet uses some Google Sheets only features that would have to be set up again from scratch, not to mention the various formatting issues that occur with those kinds of transitions, this isn't a workable solution.

It seems that it's also possible to copy the data to a new document to resolve this issue (see here and here). That shares some of the problems of exporting to Excel but also will require redoing numerous named ranges, alternating color formatting, conditional formatting, etc., so it's not a viable solution.

How do you fix this?

4 Answers 4


I used Google Sheet's versioning at File > Version history > See version history to identify precisely the version in which the error started occurring upon deletion of a row. Luckily, the version that caused this error was recent so Google Sheets still had effectively minute-by-minute versions of the edits.

The only change between the last error-free version and the first version with the error was the addition of four PNG image files to the first three rows of one the worksheet where the error was occurring. I tested to see if the error would occur once certain of those images were deleted, and by doing so I was able to tie the error to one particular image. Once that image was deleted, the error stopped and I could freely delete rows again.

This leaves me with the issue of figuring out how to get the image back in without causing the error. The strange thing about this is that the exact same image is used in another worksheet in the same spreadsheet in the exact same way and there are no errors when deleting rows on that worksheet, so it seems like there should be some way to do so.

Edit: I copied over the version of the image that was in the the error-free worksheet and it worked fine. Seems the problem was caused by the particular copy of the image that was originally in the worksheet with the error.


I just had the same problem and resolved it by right clicking on the unsyncing file in Google docs and chose: Make a copy. The copy turned out to be the most updated version, so I just deleted the original unsyncing version and renamed the copy the same as the original. All is now good again.


I had a similar problem where I got "Can't sync your changes. Please copy your recent edits, then revert your changes." every time I tried to delete a row. Making a copy of the sheet resolved my issue as I no longer had the issue in the new sheet. (WARNING: Lost my edit history as it history does not get copied).

Something I noticed and not sure if it is connected. In mine column C was a formula dependent on Column A. I had cleared column A so column C was also showing blank. But every time after I reloaded the spreadsheet after the "Can't sync your changes. Please copy your recent edits, then revert your changes." error, column C would show the old value briefly before updating to be blank again.


I received and fixed this error in Google Sheets when I tried to use the "Insert > Drawing" functionality. I encountered the error upon dragging a shape to the drawing board. It appeared to be caused by the fact I had my Apps Scripts macros tab (scripts associated with the spreadsheet) open at the same time that I was attempting to create a drawing. Once I closed the Apps Scripts / macros tab, I quit receiving the error.

Not the answer you're looking for? Browse other questions tagged or ask your own question.