3

I created a google-group mygroup and asked to also create an email address for the group, [email protected]. I want to email from my gmail account such that the sender address will be [email protected].

I went to Settings -> Accounts and Import -> Send mail as: -> Add another email address, added [email protected], checked "Treat as an alias" and clicked Next, but got a red error message saying "Please enter a valid email address".

How can I add this sender address?

2 Answers 2

4
+50

You can send email from the Google Groups address using its web page (see the steps below; they're harder to find after the recent UI changes), but you're correct that Gmail won't accept a group as a "Send mail as" address. (If that ever changes, it's probably better to uncheck the "Treat as an alias" box.)

To email from a Groups address:

  1. Go to the Groups conversation list on the web, https://groups.google.com/g/mygroup.
  2. Click the "+ New conversation" sausage near the upper left corner. (It doesn't look so much like a button.) --> That opens a New conversation in mygroup send-mail form.
  3. In that send-mail form, click the down-arrow in the From section.
  4. Pick [email protected] in the list.
  5. Compose and send.
2
  • 3
    I saw this form, but I do not see a "To" field in this form. This means that I can send a message only to the entire group - not to a specific person. Sep 4, 2020 at 5:40
  • Erel Segal-Halevi as far as I know, it can only send to the entire group. You can check the Help Center, support.google.com/groups/?hl=en . Maybe your purpose requires another Gmail account. A good way to switch between accounts is to use a separate Chrome user profile for each one, or a separate browser.
    – Jerry101
    Sep 4, 2020 at 14:53
0

It will work now like you mentioned:

I went to Settings -> Accounts and Import -> Send mail as: -> Add another email address, added [email protected], checked "Treat as an alias" and clicked Next, but got a red error message saying "Please enter a valid email address".

But with one exception: you will have to UNcheck the "Treat as an alias" option. You will now be able to change your "From" field for each email you are sending.

You can also set the new email address as you standard "From", and/or "Reply-to" if needed/wanted (source):

  • See all settings --> Accounts and import or Accounts tab.
  • In the "Send mail as" section to the right of the address you want to use
  • click "Make default".

The only thing I didn't yet manage to figure out is if we can also do this from inside the groups.google.com webUI

3
  • 1
    How di you manage to do that ? For me, no matter if I check/uncheck the "Treat as an alias" button it fails with the "Please enter a valid email address" error. I'm 100% sure the email is correct.
    – singe3
    Mar 24 at 17:47
  • It works for me, but when sending a message from gmail, the recipient will receive the message as if it was sent by the group, however the message is not propagated to the group! Any clue?
    – Riccardo
    Aug 29 at 17:11
  • Try using a plus address alias. If you email is [email protected], you can try using [email protected] with the custom reply-to email. It will work with or without the "Treat as an alias". Oct 19 at 0:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.