5

I wish for Firefox v4 to ask to remember passwords on Windows 7 for many banking sites that somehow cause this feature to be suppressed. Is there a way in Firefox or a plug-in that will allow these passwords to also be remembered?

closed as off-topic by ale, serenesat, user135384, Rubén, jonsca Apr 23 '18 at 22:34

  • This question does not appear to be about web applications within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • I don't know if this applies in the US, but in the UK, if you had your computer stolen and somebody got into your online banking as a result of this, you could be refused compensation. – Dan Blows Apr 28 '11 at 17:44
  • 4
    I'm voting to close this question as off-topic because it's a question about web browser functionality rather than using a web application. – ale Apr 23 '18 at 17:11
  • @ale Would it be better served by moving to another StackOverflow site? – WilliamKF Apr 24 '18 at 0:43
  • Super User is probably the best bet. However, this is too old to be migrated. – ale Apr 24 '18 at 13:50
5

Go to your Firefox components folder. The default path is

C:\Program Files\Mozilla Firefox\components

Now open the file nsLoginManager.js with a text viewer (Notepad or Notepad++).

Go to the function at around line 804 (varies with version of Firefox), which is:

/*
 * _isAutoCompleteDisabled
 *
 * Returns true if the page requests autocomplete be disabled for the
 * specified form input.
 */
_isAutocompleteDisabled :  function (element) {
    if (element && element.hasAttribute("autocomplete") &&
        element.getAttribute("autocomplete").toLowerCase() == "off")
        return true;

    return false;
},

Now comment out the first 3 lines, so it becomes:

/*
 * _isAutoCompleteDisabled
 *
 * Returns true if the page requests autocomplete be disabled for the
 * specified form input.
 */
_isAutocompleteDisabled :  function (element) {
    /*if (element && element.hasAttribute("autocomplete") &&
        element.getAttribute("autocomplete").toLowerCase() == "off")
        return true;*/

    return false;
},

Save it, restart Firefox and you're done.

  • Apparently that file is now inside omni.jar which is almost a zip file. I renamed to zip, could view the file and edit, but when I try to put modified file back in the .jar Windows complains about format being corrupt. – WilliamKF May 1 '11 at 15:15
  • @WilliamKF: I have changed exactly the file nsLoginManager.js in the above path; and since then it's been good. I have no idea about omni.jar. – Mehper C. Palavuzlar May 1 '11 at 18:33
  • There is no nsLoginManager.js in Firefox 4 on Windows except the one embedded inside omni.jar. – WilliamKF May 6 '11 at 0:54
  • @WilliamKF: The above solution is valid for Firefox 3.x, and at the time you asked your question, you didn't tell that you have Firefox 4. So I answered on April 28th (before your edit) without knowing you have Firefox 4. – Mehper C. Palavuzlar May 6 '11 at 6:43
  • 1
    @WilliamKF: The issue of Firefox 4 is discussed under Firefox Support Forums (see this thread). I also found a solution for omni.jar problem as described here. Hope that helps. – Mehper C. Palavuzlar May 6 '11 at 6:54
5

I'd say it would be better to use a password manager plug-in like LastPass or 1Password.

Not the answer you're looking for? Browse other questions tagged or ask your own question.