1

I recently started receiving spam emails in my Gmail inbox. They all seem to be addressed to john@aol.com. To combat this I tried to set up a filter:

Matches: to:(john@aol.com)
Do this: Delete it

When I test the filter with a search, it finds the emails correctly. But they still get through on incoming emails. What can I do?

1
0

Please use the following filter condition instead

to:(john@aol.com)

enter image description here

2
  • I'm confused. How does this differ from what the OP did? Dec 23 '20 at 21:29
  • @RockPaperLz-MaskitorCasket It is not clear where -meaning in which fields- those conditions were entered. The OP though could clarify. Dec 23 '20 at 22:35
0

I wouldn't use a filter to do this, but If you want to use the filter you need to do two things on page two of the filter creation process:

  • assign a label
  • skip the inbox (archive it)

That will result in it not being in the inbox, but it will be in all mail. You could then periodically check the label, and see if messages with that label need to be deleted.

You could go an additional step and on that same filter creation page you could also delete messages caught by the filter by checking that option. New messages would be sent to the trash and then 30 days later deleted.

Another option is to not use a filter at all. Select one of the messages and click spam. Hopefully after doing this a few times, the spam filter will be trained to move these messages to spam.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.