0

Copy and pasting, dragging images off the desktop, or uploading images through the menu of Google Slides generally works for adding images to Slides presentations. Yet with some photos (appears to be with photos larger than 5115 KB) a large blank photo with a ! appears (See below). This occurs even immediately after deleting all browsing data (clearing all cache and cookies from the browser), so it doesn't appear to be a memory issue.

One option might be to manually downsize all files before adding them to Google Slides, but that is impractical every time you have a high-resolution image. It seems like there might be a solution within Slides. I have tried changing the size of the image within the formatting options and then replacing with the original (so that it comes in as a smaller size), but I think that is just changing the visual size on Slides not the size of the file. Is there any way to do this in Slides? enter image description here

2

Instead of using drag and drop (at least for large (KB) images do the following

  1. Upload the images to Google Drive
  2. Insert the image to you presentation from Google Drive

As it was already mentioned in the question one alternative is to resize the images / photos and to save them to other formats. This can be done with the OS native app for image / photo editing. Once you get the desired height and width save your image as jpg. An alterative to use OS native app you might to use Google Drawings to edit the images.

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.