2

Until recently, I was able to add shared folders to My Drive using the Shift + Z shortcut, but now every time I try to do it, these two messages appear:

FolderName has been added to "My Drive".
The server encountered an error. Please try again later.

I know I could add a shortcut of the shared folder to Drive, but I would like to leave that as a last resort.

How can this problem be solved?

1
2

Adding a shared folder to your Drive with the Shift+Z shortcut only works if the owner of the folder has the advanced sharing option Editors can change permissions and share enabled. If this is disabled you'll get the unhelpful error message you encountered.

Steps to enable:

  1. Login to Google Drive with the account that owns the shared folder
  2. Locate the folder in your Drive
  3. Right click it and select Share
  4. In the opened dialog, click the gear icon in the top right
  5. Enable Editors can change permissions and share option

Now users you shared the folder with should be able to add them to their Drive with Shift+Z

1

I think that is a problem on the Google side, so as the message suggests, wait an try again later. In the mean time you could submit your feedback directly to Google. On Google Drive on the web click the ? button then Send feedback, fill out the form and submit it.


Related official blog article: Expanding shortcuts in Google Drive, reducing unorganized files

1

You can use add "shortcut to my drive". It does the same thing. But if you are a "Backup and Sync" user and want those folders to appear and even be reachable in your PC when you go offline you can go ahead and uninstall your "Backup and Sync" client and use the "Drive for Desktop" client instead. I don't know why Google tries to hide it into the deep partition of its website but it is a way too underrated tool that can do literally everything "Backup and Sync" can do and way much more.

0

Sometimes there might be an outage from the servers. You can check the server's status in https://www.isitdownrightnow.com.
If the above isn't the case then check if your Google Drive works with incognito mode. If it works then the problem might be extensions like CORS domain added to your browser, remove that and check.
The last option might be to contact Google and resolve it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.