2

I am trying to create a trigger for a script in google spreadsheet and upon trying to save the trigger I am getting the following error:

enter image description here

This app is blocked This app tried to access sensitive info in your Google Account. To keep your account safe, Google blocked this access.

I don't have G-Suite, I don't have an organization, I am simply using my personal Gmail account. I don't have the special account protection thing enabled. I tried using different scripts, even an empty script. What could be the problem here? I have used scripts and add-ons in the past, but haven't needed triggers yet. Is there another way to run a script daily or monthly, without this trigger functionality?

2

4 Answers 4

1

You should be able to create triggers for your own scripts.

The referred "app blocked" message only occurs on apps created by others. In order to unblock the app the developer of the corresponding app should submit it to be reviewed by Google.

Related

Questions on Stack Overflow about the same message

2
  • 3
    I get this when I go to tools > script editor, then I paste in my script (which is very simple, I even tried an empty script), then I go to triggers and when I try to save a trigger it asks me to authenticate and then this error. There aren't any other developers or even apps. What am I doing wrong? Commented Feb 23, 2021 at 20:54
  • 1
    I already read those topics, unfortunately they don't offer relevant solutions. Commented Feb 23, 2021 at 21:37
0

Just had the same problem.
My solution was, to go to "Manage Google Account" (or similar as I'm Germany it actually reads "Google-Konto verwalten") and choose "Security" on the menu (left side of the screen). There was a warning about my apps script having access to my Google data. I simply confirmed, that it was me who granted the access. After that, I could run my script without any problem.

1
  • Didn't work for me unfortunately. Can't see anthing of that sort on the security account page. Commented Jun 25, 2021 at 18:56
0

I had the same problem and I was able to fix it by using and connecting a GCP project with Google Sheets API enabled. This could be a factor of Google moving to a new editor and Apps Script.

You can follow the instructions in this link, and it gives you a sample script as well, which should work if configured properly.

https://developers.google.com/sheets/api/quickstart/apps-script

-1

In "Advanced options" in the Script editor, link the script to a platform in GCP (i.e. console.cloud.google.com looks like any project, does not have to contain anything). After that, you can authorize the script.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.