0

A few days ago I got kaspersky security cloud free and on opening google classroom, it popped up saying that google classroom was using my webcam. I checked that this was only when I launched classroom not just chrome. The camera doesn't actually turn on as the light didn't, classroom also never asked for camera permission I checked it in settings. I thought this was some type of connection with google meet but google meet uses a different website. For a day I think it didn't popup but idk if this was just me not noticing it at that moment. Should I be concerned? It started popping up again every time I opened classroom.

Edit: I discovered something. I get the kaspersky popup that google classroom is trying to use my webcam only when i dont have any other users's chrome opened. I have two accounts and if i have the other chrome opened, when i open classroom on the other user, i don't get the popup, however if the other chrome user is closed, i get the popup. I checked this several times. Any idea what's happening? I also disabled webcam access for all websites on my computer.

0

It's because probably the class you have joined might be already connected to Google Meets, and you already gave permission to access your webcam. But if the classroom you are joining is not requiring you to open your webcam that is why it is not showing you in the applications that have used your webcam recently.

If you want to turn off the access of your webcam in Google Meet then;

If you are using Chrome: Go to settings > search camera > select site settings > Select Camera OR just click on this link chrome://settings/content/camera?search=camera . After that you will see google meet there, click on it and you will see the Camera option, select block/ask to remove the access.

If you are using MacOS Safari:

  1. Launch the Safari browser app on a mac computer.
  2. Select Safari from the menubar options.
  3. Choose the Preferences… option under the Safari menu.
  4. Switch to the Websites tab within the Preferences popup window.
  5. Choose the Camera (same goes for the Microphone option under camera) in the sidebar.
  6. At the bottom of the drop-down — When visiting other websites select Deny.
6
  • Yoo i discovered something. I get the kaspersky popup that google clasroom is trying to use my webcam only when i dont have any other users's chrome opened. I have two accounts and if i have the other chrome opened, when i open classroom on the other user, i don't get the popup, however if the other account is closed, i get the popup. I checked this several times. Any idea what's happening?
    – cheezguy
    Jul 22 at 14:36
  • I am still getting the popup even though i have blocked meet from accessing my webcam.
    – cheezguy
    Jul 22 at 14:39
  • Disable all the websites as you did for google meet. Probably chrome is trying to access your webcam.
    – iftikharyk
    Jul 22 at 15:01
  • I only get the popup when I open classroom. Not other websites and I have already blocked webcam access for all websites.
    – cheezguy
    Jul 22 at 15:11
  • Where you disabled Google Meet from chrome settings, there is option called Default behaviour, turn on "Don't allow sites to use your camera" option from it. It will disable all sites to use camera
    – iftikharyk
    Jul 22 at 17:29
0

If anyone is having the same question as me, then youll get the popup when you visit youtube too. Someone asked on reddit why you get the popup on youtube, and someone answered that it was cuz youtube was checking for the camera for the live broadcast feature and that it isnt accessing it but checking it. I'm assuming the same for g class as well but im not exactly sure for what it needs the camera. Either that or maybe a bug. Im not fully sure on this answer but this seems to be possible.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.