My non-Gmail corporate email is example.com and I'm matt@example.com. I created a new Gmail account (regular, not Google Apps) and added matt@example.com as an additional "send mail as:" address and I never receive the verification email at matt@example.com. It's not in any spam folder. Note that example.com uses Gmail/Postini as the initial filter (possibly relevant that I'm using another Gmail service?) and the message isn't caught as spam there either.

Adding any other email address such as Gmail, Yahooor Hotmail works fine - I get the verification email. Seems too much of a coincidence that I receive the verification message at my personal email addresses but not my corporate one.

What am I missing?

  • 1
    @Randolf - Picky picky! :) – Matthew May 30 '11 at 5:59
  • 1
    It can seem that way, but if you look at section 3 in RFC 2606 you'll see that "example.com" (and a few others) are reserved specifically for use in examples like yours (this is important because in addition to protecting the domain names of third-parties from potentially costly unnecessary traffic, it also encourages "net neutrality" on a subtle but effective level): rfc2606.openrfc.org :) – Randolf Richardson May 30 '11 at 6:04
  • 1
    @Randolf - I know and I agree, that's why I smiled! :) – Matthew May 30 '11 at 6:06

I was't receiving the email because I had a previously-created-forgotten-about-and-not-in-production Google Apps account for example.com. As a result Gmail was delivering the verification email to the Google mail servers since from Google's point of view that domain's email is hosted by them rather than to my external example.com mailer.

  • How did you solve that? Something similar is happening to me: I had created a "me@example.com" account with Gmail (weirdly, it worked, but couldn't use it for nothing). However I deleted it already and I still don't get the confirmation e-mail in my "me@example.com" mail box (the other crappy webmail client) when adding it to my other gmail account in "send mail as". – zok Jun 8 '15 at 16:36
  • Did you make sure to get rid of the MX records associated with the domain that you deleted in Google Apps? If the MX records still exist it is possible the mail is going into the bit bucket. – Matthew Jun 9 '15 at 17:46
  • Well, I didn't use Google Apps - I simply created a "me@example.com" account with Gmail directly. I actually didn't thought that would work, was just curious about it. Surprisingly (to me) it worked, and then, when logging in on that account, Google asked me to associate that address with a (new) @gmail account. But now I'm having the same problem (as you described) and I thought that could be the reason. I posted about it here: webapps.stackexchange.com/questions/78976/… – zok Jun 9 '15 at 19:45
  • I use the term 'Google Apps' to speak generally about Google's custom-domain email services. So if you are doing email for example.com with Google, that still falls under what I was referring to as Google Apps. What if you check your MX records for your domain? Are they going to the right place? – Matthew Jun 10 '15 at 20:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.