0

Google Docs is not accepting pasted Tabs as actual tab characters (ASCII character #9). It turns them into a number of spaces. Usually four, but not always.

I'm on MacOS 11.5.1, with Firefox 90.0.2. Happy to try Safari or Chrome if you get it to work there.

Things I have tried that do not work:

  • Tools menu --> Preferences.
  • Write text in text editor (e.g. Atom, BBEdit) with "auto-expand tabs" turned off. Copy, paste in with Command-V.
  • Same but with Command-Shift-V.
  • Turn on "Match with regular expressions" in Docs. Find-and-replace four spaces with \t
  • Copy the space created by typing a Tab into Google Docs (mid-word so that it's not just moving the tab stops). Find-and-replace four spaces with that.
  • Create text in a few cells of Excel. Paste them in with Command-V or Command-Shift-V, hoping that the cells turn into tabs.
  • Same but with Google Sheets.
  • Type "a Tab b Tab c" in Word and paste that in. (Actually creates six spaces and a tab with Command-V 🤷‍♂️, and the usual 4 spaces with Shift added in.)
  • Setting an automatic substitution for replacing four spaces with a pasted-in tab or with \t.
  • Googling it.

Can anyone get this to work?

1
  • Possible duplicates / related 1, 2, 3
    – Rubén
    Aug 5 at 21:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.