1

My Gmail account is configured in Thunderbird, all works fine except - the oldest email I can access in Thunderbird from Apr 2021, while my account is almost 20 years old.

Settings:

  • imap.gmail.com on port 993 using SSL/TLS and OAuth2.
  • Copies & Folders > Message Archives > "Keep message archives in" is checked, Using "other": "All Mail on mymail@gmail.com".
  • Synchronisation & Storage > "Keep messages in all folders for this account on this computer" is checked.
  • Disk Space "Synchronise all messages locally regardless of age" is checked. Changing it months or years makes no differences, no additional mails are downloaded
  • The local directory at /Users/Me/Library/Thunderbird/2ravxxx.default/ImapMail/imap.gmail.com is around 800MB in size, while the "online" inbox is around 15GB.

How can I get all my emails in to Thunderbird?

5
  • How long ago did you add Gmail to thunderbird? you may have hit a bandwidth limit
    – Ian Hyzy
    Sep 26, 2021 at 20:05
  • @IanHyzy it's been months now. The first email in Thunderbird is from April 2021. Can't get it to download anything before that date.
    – stef
    Sep 28, 2021 at 1:38
  • Have you tried grabbing a test batch (maybe 10) of the offenders in Gmail and adding a new Label to them (e.g. "missingEmails") and then trying to sync the new IMAP folder "missingEmails" to see if they sync? ............Also, make sure you have not restricted the IMAP folder size on Gmails end: Gmail / Settings / Forwarding and POP-IMAP/IMAP Access / Folder Size Limits: "Do not limit the number of messages in an IMAP folder" Oct 18, 2021 at 3:51
  • 1
    @BlindSpots That was it, the folder size was limited. My man, you fixed a problem that was bugging me for months, thanks so much! Post the answer so I can accept it.
    – stef
    Oct 19, 2021 at 8:12
  • 1
    I should play my numbers :-) No problem! Oct 20, 2021 at 4:12

1 Answer 1

1

Remove the IMAP folder size limit within Gmail

  1. In a web browser navigate to Gmail > Settings > Forwarding and POP-IMAP (link to the tab)
  2. In the 'IMAP Access' section look for the heading "Folder Size Limits" and select 'Do not limit the number of messages in an IMAP folder'
  3. 'Save Changes'

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.