14

I use the Google Mail keyboard shortcuts a lot and I've just started working on a Mac. One shortcut I use a lot is delete, which Google Mail listens for the # key.

However, when I press the equivalent on the Mac keyboard (Alt+3) it doesn't work. I've tried pressing backspace and Fn+Backspace but no luck.

Anyone out there know the solution?

2
  • I don't have a US keyboard, but isn't it actually Shift+3?
    – slhck
    Jun 13, 2011 at 8:44
  • No it's Alt+3 for #, but either way it still doesn't work.
    – Sam Huggill
    Jun 13, 2011 at 13:20

5 Answers 5

15

It is Shift+3 within a message for Mac.
It is the same in the inbox as well

  1. You must move to the message with j/k
  2. Select a message with x
  3. Then press Shift+3

It could be that your keyboard layout is different.
Using a UK layout, it would be Option + 3 : + 3, but this does not work (Not sure why).
You can also remap your keys with the Google Labs feature : Custom keyboard shortcuts

8
  • 6
    Correct - with UK keyboard layout no combination works. Solved it using the google labs feature you suggested. Jun 13, 2011 at 15:57
  • I'd love to know why, even though I couldn't care less about this issue! :P
    – cregox
    Jun 14, 2011 at 12:47
  • TR Q keyboard is the same, couldn't get it to work. Now I have to find an appropriate (and empty!) key to remap... Oct 5, 2013 at 13:51
  • @Cawas the reason i believe is in chrome the option key is used to switch tabs... at least on my keyboard
    – David
    Nov 5, 2015 at 15:26
  • 1
    @DavidAnderton can't recall if I meant why shift+3 or why option+3, but right now I still see both as completely non-sensical key combinations a developer could choose for deleting. But, then again, so is cmd+shift+3 for screenshot...
    – cregox
    Nov 5, 2015 at 15:38
1

I am using MacBook Air M1 chip (2020) and clearly at this time of my posting this comment, using Safari browser, everything seems to work on Safari browser w.r.t. the Gmail keyboard shortcuts, except # to delete an email.

I have tried to edit Gmail keyboard shortcut to something else but keep getting error "One action per key!", which contradicts the pervious post here ^^ and the Gmail Documentation https://support.google.com/mail/answer/6594?co=GENIE.Platform%3DDesktop&hl=en#zippy=%2Cactions

0

With a Spanish Macbook keyboard I could not make it work: typing a # with neither Cmd-3 nor Shift-3 nor Cmd-Shift 3 worked...

"Google Labs feature : Custom keyboard shortcuts" worked fine (but remember to RELOAD the Gmail page before using newly defined keys).

0

Came to this question from 2011 in 2021, and was still not clear why this no longer works Out of the Box!

It turns out that Google changed the defaults. The Keyboard Shortcuts are now off by default. I found out because I'm now using a (new) GSuite account for work.

So to turn it on go to Settings > General > Keyboard shortcuts and set it to Keyboard shortcuts on:

Keyboards shortcuts

After you have done so you can use Shift+3 a.k.a. # to delete messages at your leisure!

This also means you no longer have to use the Google Lab to modify the shortcuts.

0

What works for me (2022):

  1. In gmail, click the setting icon and click "see all settings"
  2. Go to the "Advanced" tab and enable "Custom keyboard shortcuts"
  3. Refresh gmail. Now there should be a new tab called "Keyboard shortcuts"
  4. Find the shortcut for "Delete", set it to whatever you like
  5. I'd like to use d and got an error "One action per key!" This means d is already used. I find it's used by "Compose in a tab" which I never use, so I removed that. Then it works fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.