I'm using Google Chrome 12.0.742.100 on OS X 10.6.7. It seems that Gmail takes an inordinate amount of time to load (2-3 minutes) as indicated by the 'loading' circle on the tab. Some images may help explain what I mean:


The loading tab is a pinned Gmail tab.

To determine whether this is something to do with pinned tabs and priority inbox, I'll show the following images that exclude these possibilities respectively:



NB: This slow loading also occurs in a normal, non-incognito window.

I wonder if others are experiencing this type of slow loading and what the cause may be.

  • I have had this before I just cleared my cache and it went back to normal
    – Matt
    Jun 15, 2011 at 8:18
  • 2
    Can you confirm if you're experiencing the same problem using another browser?
    – Ellesa
    Jun 15, 2011 at 8:31
  • Same thing's happening with Safari 5.0.5 (6533.21.1).
    – boehj
    Jun 15, 2011 at 8:45
  • Also same thing happens on Fluid.
    – cregox
    Jun 15, 2011 at 12:12
  • This got accepted as a bug today. Hopefully it'll get squashed.
    – boehj
    Jul 28, 2011 at 8:00

5 Answers 5


As Jeff mentioned, it doesn't appear to affect the way Gmail works. According to several different Chrome Bug reports (1, 2, 3, 4), the Gmail website is attempting to load a resource that is taking forever/not loading properly.

According to the bug reports, it has something to do with this GET requested URL:

Request URL: https://mail.google.com/mail/channel/bind?VER=8&at=AF6bupMV0YlyE96Mz6Y9tRg5NS0raR6ssA&it=3125&RID=rpc&SID=304CA2227E292CA5&CI=0&AID=9&TYPE=xmlhttp&zx=2hn7zqydxypy&t=1
Request Method:GET
Status Code:200 OK

If you would like to take a look for yourself, you can do the following:

  1. Open a new tab
  2. Open the developer tools. This can be done by either going to Wrench -> Tools -> Developer Tools or pressing Ctrl + Shift + I
  3. Click on the Network button (3rd tab). You should see a message on the bottom that says "No requests captured. Reload the page to see detailed information on the network activity."
  4. In the address bar, go to gmail.com and let the page load.

You will see the network tab fill up with the back and forth requests/information between Chrome and Gmail's servers. Once you wait long enough for the logo to stop spinning, you can see what resource was causing the problem and how long it took.

This is a screenshot of my network tab - you can see that the bind resource took 3.6 minutes to load:

Click to see full-sized.

Although there are Chrome bug reports filed for this, I am going to assume it's actually a problem with Gmail.

Edit: After watching the network activity for Gmail for the last 25 minutes, I'm not sure exactly what the bind request does - it seems to be connected to everything. For me, the initial bind request includes what seems to be all of my contacts, and then a bunch of information involving contact.talk.google.com about those contacts. The bind URL seems to close after about 4 minutes and then opens a new 4 minute connection - this seems to be how Gmail watches for new emails. Mine had a bunch of [noop] entries, and then the email address and subject of a new email when it arrived.

I'm now wondering if Gmail isn't working the way it's supposed to, and the bug is with Chrome/webkit browsers that don't stop showing the "loading" graphic until all of the initial connections are closed (ie, right around 3-4 minutes when the first bind closes).

Edit 2: I filed my own Chrome bug report with this information, if anyone wants to add to it.

  • Fantastic answer. I'm going to follow this up when I get back from work. Thanks a lot.
    – boehj
    Jun 15, 2011 at 22:16
  • Been a bit short on time. I'm reading through those four bug reports right now. I'll keep you posted.
    – boehj
    Jun 17, 2011 at 0:01
  • I filed a bug report too. Hope we see some action on this.
    – boehj
    Jun 17, 2011 at 1:00
  • I added to your bug report. Thanks for putting it up. BTW, I don't really know how to accept an answer for this question but seeing as you put me onto all these bug reports, you get the prize! Thanks for your help.
    – boehj
    Jun 19, 2011 at 2:10

I have seen this, but usually it does not impact the functionality of GMail; that is, it keeps "loading" but the GMail app is fully functional in Chrome. Is that what you're seeing too?

  • Yeh, functionality is A-OK. Just curious: Has Gmail become a massive beast of a webapp?
    – boehj
    Jun 15, 2011 at 8:44

It is probably because gmail uses long server polling to update itself and chrome shows that as an open connection and keeps spinning the 'loading' icon.

We found this to happen with our apps too, in Chrome only, which use GWT and long server polling to do 'server push'.

If this is indeed the case with gmail too then its the fault of Chrome not gmail. Gmail has already 'loaded' if you can see and interact with the ui elements.


Depends on what you mean:

  1. If you mean 3 minutes to stop the "full" browser loading, but just few seconds to actually get out of the loading screen into the regular gmail interface...

    In my experience on different machines, OS'es and browsers, sometimes it stays forever. I assume it's a gmail inoffensive bug since it never gave me any performance or functionality hit.

    When it annoys me, I simply reload the tab and the "loading" stops until the next time it decides to randomly begin again. I'd bet it's related to gmail labs, tho. I usually got about 20 enabled.

  2. Now, If you mean you're taking 3 minutes on the loading screen...

    You should try removing some labs. Sometimes they conflict with each other. Use the Basic HTML if you simply can't get in and you'll be able to configure them.

    The loading screen should only take more than a dozen seconds or so if you're using a cluttered or very (I'd say more than 5 years) old machine.


Yes, I often see the same thing. I just select the address in the bar and press enter (rather than clicking reload)... then it tends to reload quickly and fine.

  • I've tried this a few times now but no dice. I wonder why this technique has worked for you, yet not for me. Anyway, I've filed a few bug reports and I'll do some more checking this evening. Thanks for your suggestion.
    – boehj
    Jun 17, 2011 at 3:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.