4

I've been facing this issue for the last 9 months or so, where WhatsApp web app would show in Arabic instead of English, which is the preferred language in my browser settings (Firefox). I should perhaps mention that I had Arabic as the third preferred language (After English the first, and French the second), but I removed it, and it still shows in Arabic.

I already tried clearing up the cookies with no success.

2 Answers 2

2

I also use Firefox and had the same problem. My WhatsApp web was being displayed in Spanish, despite my browser language was set to English. I finally fixed it by logging out of WhatsApp web and linking the device again from my phone, but first making it sure that my phone's language is set to English.
It turned out that the problem was that I used to change my phone's language from time to time. The phone's language setting is followed by the browser web version, according to this help article:
How to change WhatsApp’s language.

0

Although my iPhone's preferred language was EN, logging in to WhatsApp resulted in DE. This is a common problem when you live in a "non-EN" country - all sorts of clever developers try to sniff your language instead of just letting you decide or detecting it correctly.

You may be able to solve this issue for WhatsApp, as I did, by logging out of web.whatsapp.com, deleting your cookies for that domain and logging in again.

I managed to solve this by logging out, deleting the cookies using Chrome's F12 developer tools and then logging in again.

enter image description here

Interestingly, editing the cookie value from de to en and logging in again does not help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.