0

I have a Windows 11 laptop with Firefox installed as my primary web browser, and Brave as backup. I logged into a company Google account on my Android 12 phone, adding it as a Google Account under the Accounts settings page, and that worked just fine. I opened a mobile web browser (Firefox for Android), navigated to Google.com, and signed in, and that worked just fine.

On my laptop, however, when I try to log in to Google.com using the exact same email/password combo, it returns an incorrect password error, exactly as if I'd just entered the password wrong. (Friends, I guarantee I did not enter the password wrong. I had several different colleagues verify that both the username and password were identical to the ones I used to log in on mobile.)

This issue persists regardless of whether I use Firefox or Brave, Private/Incognito mode or regular, extensions enabled or not. I even tried deleting my PC's etc/hosts file in case that was causing a problem, but to no avail. The laptop and mobile are on the same wifi network. I tried doing "forgot password" on the laptop, but it gave me an error, saying to contact my org admin, so no luck there.

Does anyone know what's going on?

4
  • Follow the advice that you already got... contact your org admin. This because your admin might have to authorize your laptop, might have to submit a support ticket directly to Google among other posibilities. Apr 19, 2022 at 23:16
  • @Rubén that advice was for changing my password, which I don't need to do. Why would the admin have to authorize a laptop, but not a mobile device? If it's a user-agent string, that's easy enough to spoof...
    – ETL
    Apr 20, 2022 at 3:18
  • Regardeless that you get that advice when trying to change the password, as this issue occurs in a Google Workspace account and this service allows admins, among many things, restrict what devices might allowed to use company accounts (ref. support.google.com/a/answer/1734200), IMHO you should contact your org admin. Anyway, lets put this aside for a while... please add more details... are you able to use a gmail.com account on your laptop? try using Chrome instead of Firefox, if Chrome works, add the Firefox and Brave versions. P.S. Troubleshooting like questions are off-topic here. Apr 20, 2022 at 3:58
  • Turns out the simplest solutions are often, well, the simplest. UA string solved it immediately, Feel free to upvote the answer posted.
    – ETL
    Apr 20, 2022 at 4:08

1 Answer 1

0

Changing the user-agent string to one that corresponds to a mobile OS* solved this issue. It appears that for whatever reason, Google did not want to allow a desktop device to log in. (This could be a specific setting in the Google Apps Admin Panel, so that users can only sign in on mobile devices, although it's not a setting that I've ever heard of.)

*for example, Mozilla/5.0 (Linux; Android 11; Pixel 5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/90.0.4430.91 Mobile Safari/537.36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.