1

I created a GitHub label in Gmail in order to collect Emails from github.

a GitHub label

Then created a filter to catch mails from github.com domain

create a filter

In the operation step, I selected Apply the label: GitHub to want to move the mails under the label(and not appear in the default mail box).

create a rule

I can also confirm the setting for it in the Filters and Blocked Addresses page.

settings status

However, when a mail sent from noreply@github.com, it still existing in the Inbox but can't find in the labeled GitHub folder.

Which setting is wrong? How can it send to the labeled folder but not the Inbox by the right rule?

1 Answer 1

0

To not have the email get the "inbox" label, put a check in the "Skip the inbox (Archive it)" option at the top of the list.

If the message isn't getting the "Github" label attached it is possible that the information in the "From" and "To" lines is incorrect.

I get the best results when I start the filter creation from an existing email using the "More/Filter messages like these" command.

I looked at my couple of dozen filters and only 2 use the "To" value, that would be the place I would start looking.

Also when you edit the filter you should see in the background a list of messages it finds, if it isn't finding any, that is a sign that something is wrong with the search statements.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.