2

Allow Facebook business page to be viewed for non-logged in users

When we go to out business page, facebook.com/businessnamehere and you're not logged in, it gives the message "You must log in to continue.". Naturally this results in the page not being indexed by Google.

Settings under Select profile -> Business -> Settings -> Privacy -> Facebook Page Information, shows that:

  • Who can see your future posts? Public
  • Do you want search engines outside of Facebook to link to your Page? Yes
  • Allow people to message your Page? On

What more needs to be configured for the Business to be viewed without being logged in, and indexed by search engines?

1 Answer 1

2

We finally managed to fix it, by switching back to the old layout for business, and there we could remove the "country restriction" that was set.

That setting is not present in the new current layout.

1
  • Welcome to Web Applications. Thanks for returning and sharing the solution here. Contratulations for the reputation points you have earned that gave you several participation privileges on this site like participating in Web Applications Meta, Web Applications Chat, upvoting among others. Whenever you have time, please checkout other questions on this site and help us moderating this site, i.e. by upvoting those questions that are most useful and appropriate. Jan 30, 2023 at 17:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.