1

I'm in Greece, using Wind Hellas as ISP. For some reason, I have two public IPs, one in Athens (Greece) and another in Tel Aviv (Israel).

When I'm using google.com, it consistently selects the Israel IP as my location, which makes all my search results prioritize Israelian results. Shopping is also in Tel Aviv using Israel money.

Google's own documentation has no effect on google.com.

How can I make google.com ignore my supposed Israel geolocation and use the one from Greece instead?

1 Answer 1

2

Google Help Forums has provided an answer to your dilemma worth investigating further.

https://support.google.com/accounts/thread/161342323/update-change-location-of-google-account?hl=en

A number of solutions are proposed according to what device/OS/application you are using.

For example:

In Windows Computer, Select Settings, Select Network & internet> Network & sharing center>Change adaptor Settings>Select properties> Follow the instructions and Select Obtain an ip address Automatically,

1
  • 1
    This has nothing to do with my IP-settings in Windows (they are automatic by the router/ISP). Nor did the link above help directly, but lead me onto the right path. On My Account. the location is correct. But on google.com it is wrong. On the bottom right part of google.com, there is Settings -> Search Settings -> Region Settings, which can be changed to anything. And then it works!
    – Reyhn
    Commented Jan 10, 2023 at 14:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.