On Windows 10, using Microsoft Edge, Google Calendar asks me to allow it to open web calendar links.

Occasionally, Google Calendar pops a pop-up message asking me to let it open web calendar links. I did a thorough search and tried the suggested solutions. Some of them were relevant to Chrome and some to Windows 11. Found nothing for the Windows 10 / Edge combination.

Edit: I got the screenshot

enter image description here

  • 1
    How do Google Calendar asks you to allow it to open web calendar links? Please search this site and the MS Edge and Google Calendar resources for end users thoroughly, share what you tried and what you found and why it didn't meet your needs. Ref How to Ask. Mar 22 at 17:26
  • 1
    From time to time, Google Calendar pops a pop-up message, asking me to let it open web calendar links. I'll try to capture the message next time it happens. Of course, I did a thorough search and tried the suggested solutions. Some of them were relevant to Chrome and some to Windows 11. Found nothing for the Windows 10 / Edge combination.
    – Avi
    Mar 22 at 18:18
  • Please add the details provide in the comment direclty into the quesition body. Mar 22 at 18:49
  • Is the screentshot from webapps.stackexchange.com/q/168857/88163 similar to what you see in Edge? Mar 22 at 18:52
  • 1
    @Flimm Please bear in mind that comments are not intended for extended discussions. I answered this questions because it's about Microsoft Edge and as the OP mentioned the related info was not clear how to use it in this case. Regarding the deletion of the other question I will add a comment about that in your question. Mar 27 at 12:46

1 Answer 1



The dialog is a standard feature of some modern web browsers. It's related to the web browser setting Protocol Handler. This is responding to a check done by Google Calendar. This is not shown all the time because the default option might be to ignore it or the app use an algorithm to not be too anonying. The details about how Google Calendar internally works are beyond the scope of Web Applications.

Review the Protocol Handler settings

Microsoft Edge

In Microsoft Edge go to


Or click the Settings button then type "protocol handlers" in the search box.

This is my setup:

  • Microft Edge for Mac Version 111.0.1661.54 (Official build) (arm64)
  • MacOS Ventura 13.2.1

In my case the above link takes me to a screen that looks as follow:

Protocol Handler

Snapshoots showing how the Microsft Edge toolbar looks when opening Google Calendar:

Microsoft Edge for Mac Toolbar - Google Calendar

When clicking in the protocols handler (protocols handler) button, the following dialog is opened:

Allow calendar.google.com to open all web calendar links

Google Chrome

In Microsoft Chrome go to


Or click the three dots button, then Settings. In the search box type Handlers. Click in Additional Permissions > Protocol Handlers

I'm using

  • Chrome Version 111.0.5563.110 (Official Build) (arm64)

This is what is shown to me:

Chrome Protocol Handlers


Firefox handle the protocol handlers differently than Microsoft Edge and Chrome. It will be necessary to make use of a small script.

  1. Copy th following script
    window.navigator.registerProtocolHandler("webcal", "https://calendar.google.com/calendar/render?cid=%s", "Google Calendar");
  2. In Firefox, go to https://calendar.google.com. Firefox - Google Calendar
  3. Open the web browser console. If your keyboard functions keys press F12 to open the web developer tools. In Mac press Command+Opt+I Web console
  4. Paste the script. You might be warned to not fun scripts from strangers and might be required to type allow paste.
  5. Click Run
  6. A bar will be shown in the top of the web page asking to confirm to add Google Calendar as an application to open webcal files. Click Add application. Confirm calendar.google.com as application of webcal links -> Add application

Then in Firefox > Settings > Applications, you can manage the application to be used to handle webcal links.

Settings - Applications


You might be seeing a dialog from a old version or maybe the differences of what each other are seeing are due to the operative system, anyway that is not really important, but just in case as a good practice regularly verify that your operative system has installed all the critical updates and that your web browser is automatically updated.


Web Applications

Super User


  • I upvoted your answer.
    – Flimm
    Mar 27 at 10:11
  • 1
    Thank you for your answer. I followed your steps in the Edge's settings and found that google calendar appeared as "default" and "blocked". I removed the blocked entry. Let's see how this pans out.
    – Avi
    Mar 30 at 10:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.