The Important label shows up on the left sidebar, and I want to get rid of it. I can hide it under the "X more" dropdown, but that doesn't get rid of it but only hides it. Also I don't want to mess with Greasemonkey scripts, as that also only hides the "Important" label instead of removing it completely.

Also note that I'm not asking about getting rid of the yellow important markers, or preventing messages from going into the important category, but getting rid of the category itself, completely.

3 Answers 3

  1. Go to Mail Settings
  2. Go to Inbox tab
  3. In the Importance markers category, select No markers
  4. In the Inbox sections category, at Important, click on Options
  5. From the dropmenu select Remove section

This way, you don't have the markers anymore and you get rid of the category as well.

Also, you might want to set your Inbox type to Classic.

  • 1
    My Inbox type was set to classic. I changed it to "Priority Inbox", modified the settings as you said, then changed back to classic, but the Important label is still under the list of hidden labels on the left sidebar.
    – Jamie
    Commented Jul 16, 2011 at 12:45
  • 1
    It's a system label, just as sent mail, drafts, spam and so on, so you can't remove it permanently.
    – Alex
    Commented Jul 16, 2011 at 13:14
  • 2
    Seriously? That really sucks
    – Jamie
    Commented Jul 16, 2011 at 13:59

Go to SettingsFilters and create a new filter. Enter @ in the From field, save it. In the save box select Never mark as important and save. That's it, all new messages should come into your Inbox.

  • This answer is still relevant today. And the only one. Will confirm it works fine and remove the Important label from IMAP.
    – trss
    Commented Mar 13, 2018 at 18:41

Modification to the @Nemo's recipe:

I actually like the important label, but Google was marking a lot of material that was in the promo tab as important. yeah, I want to read it, but not in my priority mailbox.

"Include the words" field can have any search you want in it, but you get a warning flag. Important seems to be set inbound so the warning flag can be ignored.

enter image description here

Not the answer you're looking for? Browse other questions tagged or ask your own question.