12

Some time during the past week or so, Google search started automatically translating some search results from English to German (my native language). This affects the headline, the preview snippet, and the site itself if you click on the result. Translated results have a small text "Translated by Google" and a link saying "Show original (English)", which are easy to miss, as seen in the screenshot. This is "feature" extremely annoying and I have been unsuccessful in finding a way to disable that.

Image of a google search result showing the URL of googles translation service

When you click these results in Chrome, it will go to the site, load it in English, and then use Chrome's translation function to translate it to German after a few hundred milliseconds, which is annoying.

In Firefox however, the function is even more disruptive, because it sends you to a different domain entirely, without telling you, as seen in the hover text in the screenshot. It is only when you want to do something interactive on the site and it breaks, that you realize you have been lured into what can only be called a man-in-the-middle (MITM) attack.

Things I have tried so far:

  • You can click "Show Original (English)" (or "Original ansehen (English)" in German screenshot above). That will lead you to the original domain, but only for that result. And it's easy to miss.
  • In Chrome, this can be prevented by deactivating Google Translate completely in the Chrome settings (not Google search settings). The search result title and snippet will still be translated though.
  • Setting the "Results language filter" to include English and German in the Google search "Language and region settings" does not help
  • Setting the "Display language" to English does prevent translation to German, so this is a viable workaround if you are comfortable using the English interface. But I'm concerned that this will now translate German results to English.

So, has anyone found a setting to turn this "feature" MITM-attack off?

3
  • Logging out from my Google account helped but that can't really be the solution.
    – ChrsBr
    Dec 18, 2023 at 16:07
  • I have exactly the same problem on ios wirh safari and it also started 1-2 weeks ago. I dont know how to stop it
    – C. Hediger
    Dec 18, 2023 at 22:34
  • I've the same problem! Why companies make such a drastic change in UX without user's approval/preference. It's so stupid. Feb 2 at 22:18

2 Answers 2

7

Update: it seems that the wider roll-out of the feature has been cancelled by Google. At least on my side, the feature is no longer offered. I'm seeing similar comments on social networks. You should be able to uninstall the extension for now!


I didn't find a solution neither, so I made a small browser extension. It seems that this feature is server-side rendered, so the current only solution is DOM manipulation.

This reverting/cleaning up the translations (and buttons) added by Google. It uses a MutationObserver to watch for additional fetched results by scrolling down. It also auto redirect away from the Google Translate proxy to original website URL (like some redirect AMP to HTML extensions). I am looking to simply block the request to their proxy: currently the extension still loads their proxied content in order to be able to redirect.

0
3

In your web browser go to the Language settings page.

Change preferred language to English and set country to US (I didn't test other countries).

In case link is broken/changed in the future here are step by step instructions how to get there:

Google Account page -> Personal Info tab -> General preferences for the web -> Language -> Preferred language -> [pencil icon].

Update: After changing my preferred language back to my native one again, it doesn't translate pages for me anymore and I have no clue whether I can turn this option on again. Maybe this feature is no longer there...

3
  • 1
    That was already set to "English (US)" for me, so changing the preferred language alone doesn't help. But I don't really want to change my region, because sometimes it's quite useful to get local results specific to my country. Just not translated.
    – Fritz
    Dec 22, 2023 at 13:30
  • Funnily enough, Google had automatically added Corsican to my "Other languages", which I don't speak at all. :-D
    – Fritz
    Dec 22, 2023 at 13:31
  • @Fritz that's weird. It stopped translating anything as soon as I changed preferred language (it doesn't translate pages from my native language to english) I still get results targeted for my (non-US) local area in local language as well as not translated english results Dec 22, 2023 at 14:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.