81

Gmail keeps populating the To field with an out of date e-mail address that I no longer contact.

The email address isn't in my address book but I did use it a lot previously (the contact has since changed company and email address).

How do I tell Gmail to never show it to me again?

1

4 Answers 4

63

Delete their email address in Google Contacts.

6
  • 3
    I have deleted the contact but when I go back to Gmail and type the first letter the name with the whole email address appear in the search box.
    – user25575
    Oct 12, 2012 at 8:52
  • 4
    @dhaval Reload Gmail and search your contacts for the email address to make sure you really got rid of it. Oct 12, 2012 at 12:04
  • google: a shortcut similar to the one use to delete a suggested url would be handy (ctrl+del)
    – JinSnow
    Aug 24, 2016 at 8:20
  • 2
    In case anyone thinks they're going crazy, this doesn't ALWAYS work. I have an email that is!not!in!my!contacts! and can not be made to go away.
    – tbone
    Mar 31, 2018 at 16:27
  • 4
    There seems to be no such thing as "Gmail Contacts", so this answer might be outdated. There is "Google Contacts" contacts.google.com/?hl=en Jul 15, 2019 at 1:33
12

Remember that anyone you reply to in GMail gets a contact record created for them!

To remove an unwanted autocomplete email address in GMail, remove the unwanted contact record.

  • Select "contacts" from the drop-down menu at the top left.

    GMail contacts menu

  • search for the unwanted contact in your address book by typing their name (or email, type it as you usually do in the to: field) in the search box

    GMail contacts search

  • open the contact, then use the "more" menu at the top middle to select delete.

    GMail delete contact

Once the contact is deleted, the autocomplete in the to: field for that contact name/email will no longer occur.

(sorry Blake Edwards, you were merely the example! No offense intended!)

2
  • 4
    As of March 2018, this no longer works in all cases.
    – tbone
    Mar 31, 2018 at 16:29
  • 1
    worked April 2019, did refresh GMail page after making changes. In what circumstance did it not work?
    – rob
    Apr 29, 2019 at 12:15
11

Go to Contacts then search for the email address, select it, and delete it. It is probably under "All Contacts" and pops up because you used it frequently in the past.

10

As of July 2019, Google must have changed the setup, making outdated the other answers given.

What works right now is deleting the address in Google Contacts.

Simply searching your contacts may not be sufficient - but you can begin typing the email in the Search field and when it shows up, click on it. That will bring up a Contacts "card" for that email, even if it is not a full contact that you have created. Select the three vertical dots at the top right, and Delete is one of the options.

0

Not the answer you're looking for? Browse other questions tagged or ask your own question.