I'm trying to log in to the CakePHP website using Open ID: http://ask.cakephp.org/users/login

The most correct looking URL I've found is: https://www.google.com/accounts/o8/id

..but I can't properly determine what I'm supposed to enter for my open ID, as it rejects everything that I try putting in.

Is the cake site just broken, or do I have the wrong URL?


On most sites you can use your Google profile link when logging in to OpenID. E.g. http://www.google.com/profiles/your.name.here

Before Google profile OpenID support you had to use https://www.google.com/accounts/o8/id

You can read more about it at Jeff Atwood blog post: Google Offers Named OpenIDs.

However, it appears, that at ask.cakephp.org Google profile URLs are not working. As noted by Greg, if you are logged in to your google account, google.com will work as OpenID url there.

  • It isn't working, even though I am logged in to my google account. "Returned identity did not match claimed identity" =/ – Brad Koch Sep 14 '11 at 20:33
  • Can you login to any other site using your Google OpenID? I can log in to ask.cakephp.org with google.com as well as with https://www.google.com/accounts/o8/id. Maybe there is an issues with your Google OpenID. – Domas Sep 16 '11 at 11:14
  • Yup, that's how I authenticate to StackOverflow/etc. I also had a friend try it; didn't work for them either. – Brad Koch Sep 27 '11 at 20:04

My original solution seems to not be as useful any more because they have changed the page. I have it at the end of the post just for reference

New Solution 2014-08-08

  1. Goto https://www.google.com/settings
  2. Sign in with your account
    • If you have a google+ account then you should have links for:
      1. Add photo;
      2. Edit profile; and
      3. View profile.
  3. If you copy the address for one of those it will be like
    • https://plus.google.com/{YOUR_PROFILE_NUMBER}/{EXTRA STUFF}
  4. Remove the /{EXTRA_STUFF} and that can be used as your OpenID
    • Thanks to kevin kox to also suggesting that you can replace plus.google.com with profiles.google.com as your OpenId, though you don't need to.

Original Solution

None of the other answers worked for me. However, what did was following the below steps.

NOTE: you should be able to skip some of the steps and go straight to the privacy link.

  1. Log into your account in Google
  2. Click on the profile down arrow
  3. Click the Privacy Link
  4. On the right will be the link to your Google Open ID URL
    • Mine was https://plus.google.com/{RANDOM_NUMBER}, where the random number is specific to my profile

Note that you might not get this unless you have a Google+ account.


To use the Google OpenID with Google Apps (in my case, a gmail business package, where my ID is NOT @gmail.com) it was REALLY hidden.

If you visit your account page ( eg https://www.google.com/settings/account ) and view-source, search for "https://profiles.google.com/" There you will find the long mysterious number that is the URL for your OpenID.

  • The links don't work sometimes if you have a corp account which blocks it from having a +1 account. – Matt Vukomanovic Aug 8 '14 at 2:30

This is a little complicated.

First there is the "Google OpenID URL" or https://www.google.com/accounts/o8/id. This is useful when signing up or logging in as it will redirect to the proper URL.

You can also use your Google+ profile URL. Go to https://plus.google.com and click "profile". You will get a URL like https://plus.google.com/112323959773786487818/posts. Remove the end to get https://plus.google.com/112323959773786487818 and you can use this URL (I think this is the new recommended way now).

However, these all redirect to your true Google OpenID URL. The URL is your Google Profile address. This is your Google+ user ID after https://profiles.google.com. For example, my OpenID URL is https://profiles.google.com/112323959773786487818. This URL is useful when you are inputting your OpenID URL into an application without logging in.


Just enter google.com (whomever is your Open ID provider)


Make sure you're logged in to Google (or whomever is your Open ID provider) before entering their address.

  • Doesn't work for me. I get "Returned identity did not match claimed identity". Hence the whole suspicion of their site being broken. – Brad Koch Sep 14 '11 at 20:14

protected by Community Jul 16 '14 at 8:09

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.