Members are trying to accept invitations to a board today and the emailed link is leaving them without any success. When we test drove the "add members" function on Monday the link directed one to sign-in or log-in and create an account. Has something changed?

  • What is happening when they click on the link? Are they getting an error message? What browser are they using? – Daniel LeCheminant Sep 21 '11 at 22:29
  • 1
    @DanielLeCheminant I seem to be in the same situation. I created an account on Trello, requested an invitation to a board (out of band), got the invitation e-mail (sent 2011-09-24 03:15Z), clicked on the link (around 2011-09-24 11:30Z), and was redirected immediately to the usual board URL where I saw what seems to be exactly the same page as before (it's a public board). I'm still not a member of the board, and there doesn't seem to be any kind of “accept invitation” or “join board” button. I tried in both Chrome 14 and Firefox 5. – Gilles 'SO- stop being evil' Sep 24 '11 at 11:50
  • I'm also having an issue with people not being able to accept invitations. In my case, the two people I had invited, both got a message saying 'unauthorized' when they clicked on the link in the invitation. Both were also using Internet Explorer. Any ideas? – user13827 Oct 3 '11 at 23:42
  • What version of Internet Explorer were they using? If it was less than version 9, they may have hit this bug: trello.com/card/board/… – Daniel LeCheminant Oct 4 '11 at 0:33

I'm not sure if this is the issue that you're facing, but there is a bug in Trello that prevents people from accepting invitations to public boards.

(The fix for that will go out with the next release of Trello)

| improve this answer | |
  • 1
    I've now clicked my invite link again, and this time I saw an button to accept the invitation, which worked. I guess I'm confirming the fix works. – Gilles 'SO- stop being evil' Sep 30 '11 at 23:42

Not the answer you're looking for? Browse other questions tagged or ask your own question.