My brother and I used to play Star Fox 64 when we were kids, and when we did dog fights, we always loved doing barrel rolls

Barrel Roll

so I decided to search for the quote that they always said the game in tutorial. So I start typing

"do a"

and well Google started auto-completing it for me. That's good so before I move to the suggested item Google decides it is going to make me sick.

Google: don't do a barrel roll

I know Easter eggs are all good and great but now I am afraid for when I need to search Google that something happens unexpectedly. I didn't even type in the full query. I just want to search Google.. you know without all the fireworks and barrel rolls.

I love Google Search so is there an option/extension to stop these features?

  • 1
    Just as a note - it works on Chrome, Firefox and Safari. Opera does "tilt" and "askew" but not "do a barrel roll". IE9 (unsurprisingly) does nothing.
    – ChrisF
    Nov 3, 2011 at 21:08
  • That is awesome. +1 to Google. 8-) Nov 6, 2011 at 12:43
  • The same with the word "askew" I tried to search it, because I need some information about, and was not able too read the page. google should have a "serious" mode. and a "free time" mode. Edit I foud a easy way to stop any easter egg put in a space and a dot after the search [do a barrel roll .]
    – user14633
    Nov 6, 2011 at 14:41
  • No idea why, but this has never worked for me in any browser.
    – JohnFx
    Nov 6, 2011 at 16:33

1 Answer 1


You can avoid Google doing a barrel roll by encapsulating your query in quotation marks: "do a barrel roll" will not, ironically enough, do a barrel roll.

This should work for all easter egg queries: quotation marks signal to Google that it should search for the literal string instead of interpreting it to mean something else.


This of course doesn't work when Google Instant is turned on, as Google will submit the search query before you can finish encapsulating the query in quotation marks. Unfortunately, this is a limitation/"feature" of Google Instant: to prevent Google from submitting the query before you're finished typing it, you'd have to disable Google Instant.

Beyond this, it's possible to disable certain types of Easter eggs, provided you know the nature of the Easter egg beforehand. You could, for instance, prevent the do a barrel roll Easter egg by adding the following snippet to your browser's custom stylesheet:

body {
  -webkit-animation-name: none;
  -moz-animation-name: none;

But since this would affect every <body> tag on every webpage, it's not ideal either.

You could get around this by using Stylish, which allows you to specify site-specific custom stylesheets ("userstyles"). Creating a userstyle with the following should work:

@-moz-document: domain("google.com")
@-webkit-document: domain("google.com")
@document: domain("google.com")

body {
  -webkit-animation-name: none;
  -moz-animation-name: none;

Of course, while this would allow you to disable this specific Easter egg, Google can and most likely will come up with new ones that do unexpected things in the name of being quirky. Without disabling JavaScript or Google Instant, it'd be nigh impossible to prevent them from happening at least once.

  • Hmm, this works if you have the full query. For example go to google.com start off typing "do a even with the initial quotation mark it rolls meaning that the only way for me to avoid this will be to avoid Google Instant (auto complete) altogether.
    – phwd
    Nov 3, 2011 at 20:25
  • @phwd Right: Google handles the query as you're typing it when Google Instant is on. One of the many reasons why I hate Google Instant. Because what Google considers an Easter egg is determined server-side and all Easter eggs are unique, you'd only be able to counteract known Easter eggs.
    – user10884
    Nov 3, 2011 at 20:37
  • Just a side note: Because this Easter egg was built in HTML5, it doesn't work on all browsers. I'm on Firefox 3.6 and it doesn't work here. Nov 3, 2011 at 20:46
  • @MehperC.Palavuzlar Doesn't work in any released version of IE, supposedly buggy/non-working in any version in Opera, works only in Firefox 5.0+.
    – user10884
    Nov 3, 2011 at 20:50
  • @MarkTrapp: That's right. It seems only to work with Firefox 5.0+ and Chrome. Nov 3, 2011 at 21:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.