3

I've a problem with Gmail.

Long time ago, I created a filter for incoming e-mails with a specific address, and gave them a specific label. A few weeks ago, I've deleted the filter and my filter-list is completely empty.

But incoming emails gets still the label from my old filter.

What can I do? There is no filter to delete, and Gmail labels the emails itself.

  • 1
    That's...weird. Are these new messages or are they being added to existing threaded messages? – ale Jan 19 '12 at 15:06
  • No, complete new Messages! I've deleted the created Label, and the messages. But they appear on every new mail. – Bastian Gruber Jan 19 '12 at 15:25
  • Well, if it happened for just a little while I'd call it a caching issue. If it's still happening, and you don't have any other filters that might be involved I'd say it's a bug. You should report it. – ale Jan 20 '12 at 13:42
1

Under "Account and Imports" tab in the settings you can setup mail forwarding. I believe this will automatically label it with the email address as long as that is setup. I suggest logging into that email you want to forward things from and go into it's options and having all emails forwarded to your account. You can then remove the forwarding in Google and they should not be labelled any more.

Otherwise you will have to deal with it being labelled.

In case that sounds confusing: Basically setup forwarding from the email you want to forward from instead of setting it up through "Accounts and Imports".

  • i think gmail labels the emails which are coming into my inbox. so, it doesn't matter where they are from! – Bastian Gruber Jan 20 '12 at 15:20
  • So weird all this situation is, so weird is your right answer! :D I really cannot unterstand how gmail is activating this filter, but it really seems it has stopped!! Thanks a lot!!! – Bastian Gruber Jan 20 '12 at 15:29
0

Accounts in the Accounts and Import tab is not the only possible cause. Forwarding addresses can also block filters from being deactivated and finally deleted from the gmail servers if the address is specified in the filter, at least for forwarding. So if the address in the filter is also a forwarding address then also remove the forwarding address in the Forwarding and POP/IMAP tab. Filters that are blocked by forwarding addresses are still present and active on the gmail servers even though you've removed the filter from your settings. Once the filter has ceased its operation it's because it's been deleted from the gmail servers and you can safely add the blocking forwarding address again if you want. This procedure is worth a try. z

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.