56

I noticed that when I open up Gmail on Google Chrome, a popup near the top asks me if I want to let Gmail be my "mailto:" handler.

If I select "No," I'm assuming that Gmail will no longer ask me to be a mailto: handler. But then let's say I change my mind and do want Gmail to handle mailto: links, how do I get the popup to appear again?

1
  • 3
    Did any of the answers work for you? If so, could you please accept that answer? I know one of them just solved this issue for me.
    – oKtosiTe
    Commented Feb 25, 2013 at 9:37

4 Answers 4

70

Access Gmail, and click an icon of the shape of overlapped double diamonds, next to the star icon in the omni-box where the URL is displayed.

diamonds

If you don't see it, try reload the page.

4
  • 3
    Wow. Mine has been set to 'ignore' for a long time. Thanks.
    – bozdoz
    Commented Jan 25, 2014 at 2:10
  • NB: on Windows 7, this may not work if you lack admin rights: you'll get a password prompt from Windows and no error message, but the change doesn't happen. (In the handlers list, 'mailto' stays assigned to 'none' site.)
    – norz
    Commented Jul 2, 2014 at 8:47
  • Thanks, I run my Google Apps mail as an application shortcut so I've never actually seen the address bar and therefore was never aware that the option was on there to install the handler!
    – ProNotion
    Commented Oct 27, 2014 at 9:58
  • If you somehow missed the opportunity and said 'no' after the diamond, your change to undo that is under chrome://settings/handlers (yes, answering my own sub-question)
    – Frank N
    Commented Sep 12, 2019 at 7:01
16
  1. Click the Chrome Menu icon on the browser toolbar.
  2. Select Options (Preferences in Mac and Linux; Settings in Chrome OS) > Under the Hood.
  3. Click Content settings.
  4. In the dialog that appears, find the “Handlers” section:
  5. Select “Allow sites to ask to become default handlers for protocols."
  6. Click Manage handlers and Delete Gmail from Ignored protocol handlers
  7. Logout and Login to Gmail and click the small grey icon in the omnibox
  8. Select Allow Gmail to open email links
4
  • 4
    Doesn't work here, there's no mailto under handlers and allthough i have it set to 'allow sites .... ' there is no question to handle emails even after closing and opening gmail / chrome ..
    – user26958
    Commented Oct 20, 2012 at 15:10
  • Same here. This answer is not adequate and the question remains unanswered. Any help out there please? Commented Oct 24, 2012 at 17:48
  • This didn't help me and looks like it will only work if you have previously told it not to handle it. Mulogics answer below seems to work perfectly though.
    – Chris
    Commented Feb 27, 2013 at 18:06
  • There is no Manage handlers button Commented Dec 11, 2017 at 18:41
5

A quick google turns up this: http://updates.html5rocks.com/2012/02/Getting-Gmail-to-handle-all-mailto-links-with-registerProtocolHandler I had to click a button in the URL field next to the star to select GMail as protocol handler.

It doesn't work on Windows 8 however, must be a change in the API. If I look into chrome://settings/handlers, I should see an entry then, but I am not able to select GMail in the dropdown.

Edit (Febr 2013): As stated in the comments it seems to work now.

2
  • Works in windows 8 for me. Maybe they fixed whatever the problem was.
    – Chris
    Commented Feb 27, 2013 at 18:07
  • Indeed, it works for me now, too. Commented Feb 27, 2013 at 22:10
1

Go to:

chrome://settings/handlers

Brings up a dialog box

enter image description here

And select mail.google.com and click done

enter image description here

1
  • 2
    Looks like this dialog box is no longer in the Chrome settings. . .
    – Reid
    Commented Jul 1, 2017 at 23:08

Not the answer you're looking for? Browse other questions tagged or ask your own question.