I'm trying to hook up a Twitter account with a newly created Facebook business page.

Inside my Twitter settings, I have set everything up accordingly, but it is not working. Tweets are simply not being displayed on the Facebook page.

When I change the settings so that tweets are sent to my personal Facebook profile, there is no problem whatsoever. It is only being difficult when it comes to actual PAGES (I have tried it with a few other pages and still no dice).

Has anybody experienced this before?

How did you solve the problem?

  • I've just tried it now and I'm getting the same thing. Really annoying!!
    – Rob
    Mar 19, 2012 at 11:19
  • It's very frustrating, eh.
    – Leeloo
    Mar 19, 2012 at 18:03
  • I am having the same problem. I run an internet marketing business and clients are very frustrated that they are paying for this as part of their monthly package and it is not working. It is only happening to the ones I set up in March, everything I set up in the past is working fine. I cannot find a program that will link them without changing the tweets (Well, haven't so far). I did email Twitter for support, though, and if they answer back with anything for me, I will let you know what the answer is, but I am sure they are going to send some automated message on how to set the stuff up toge
    – user18358
    Mar 22, 2012 at 16:02
  • ... together, which I have already done. (I don't know if you did it, but disconnecting and clearing my cookies and cache did not work for me either.)
    – user18358
    Mar 22, 2012 at 16:02
  • I also sent Twitter a detailed support ticket outlining the problem. I haven't heard a response yet, which comes as no surprise.
    – Leeloo
    Mar 23, 2012 at 2:46

2 Answers 2


I'm having the exact same problem - goes through the approval process fine, but nothing appears on the page. As you say, profile is working fine, just pages. I tried different accounts and browsers, as well as a few tricks, same result. I can only assume it's a bug as the whole Twitter Facebook thing has been shifty this month. One workaround is to use the facebook app Selective Tweets. This will post to pages; however unlike the native twitter app, each tweet you want to go to the facebook page you must end with #fb, hence the whole "Selective" thing. But at least they show up (and the #fb tag won't show on the page).

  • Thanks, Joe. I might just try again in a few weeks. I'm not planning on launching the app until later this year, so hopefully they've sorted out the problem before then. :)
    – Leeloo
    Mar 17, 2012 at 0:53

I have not been able to reproduce this.

Here are my steps

  1. Go to http://apps.facebook.com/twitter (which will tell you to do 2)
  2. Go to http://twitter.com/settings/profile
  3. Connect to your Facebook account (your personal one)
  4. Select my Facebook page: <Your Page>
  5. Tweet away

Though based on this https://support.twitter.com/articles/31113, you may have problems

Note: If you have previously removed the Twitter app from the app settings in your Page Manager on Facebook, there is currently no way to reconnect. We are working on a fix and hope to have one soon

Things I have noticed, if you use this link https://apps.facebook.com/twitter/?fb_page_id=<PAGE_ID> it deselects the settings. So you have to re-enable it. So try not to use the settings through the page manager but from your personal profile, i.e. the bare link https://apps.facebook.com/twitter/

Based on how Facebook previously worked you were not redirected to your personal profile when adding apps to your Pages. So I think this is what Twitter is trying to resolve.

I'm sure this has been tried before (and if this is indeed a bug, I don't I want to remove my application from my page) but try the following steps (in order):

  • Deselect pages from all Twitter accounts and save (on Twitter.com side)
  • Disconnect from all Twitter accounts (on Twitter.com side)
  • Remove the Manage my pages permissions
  • Remove the Post on my behalf permissions
  • Remove the app
  • Logout Twitter
  • Logout Facebook
  • Clear cookies (You can use Edit this cookie to selectively clear cookies)

This is by no means the solution but something to try because I cannot actually reproduce the problem.

Not the answer you're looking for? Browse other questions tagged or ask your own question.