I am using Rdio to automatically (i.e update my timeline activity) share my stream of songs played through their web application. Unfortunately a while back, it suddenly stopped posting the data.

I am not really interested in what friends see my songs but there is value to be found in the data left at facebook.com/<username>/music for me.

So I tried the advice given at I'm not seeing any updates, did I do it wrong? which states that you must remove the application. I removed the application and have now re-enabled the application. Same problem with automatic stream sharing.

Alright, well I tried using some of the previous songs to share at http://www.rdio.com/#/people/<username>/history/, that doesn't work because it continuously chokes on an error. Instead, I tried from a specific album and was able to successfully share a post but not automatically update my timeline activity.

Between the constant chokes on error, and delays in time it takes to load a page I don't think I can hold my sanity any longer to resolve this issue and am running out of ideas.

Is there a way to fix this?

My next step will be clearing cookies, though I rather not as it would be annoying for me to sacrifice cookies for all others apps/websites just for Rdio. Also I don't think cookies have anything to do with it. The error occurs for Rdio for Mac and Rdio for iPhone.


1 Answer 1


If you want to check what rights a Facebook Application has to post to your wall you should check it's settings on the Facebook App Settings page. Find the Rdio app line and click "Edit Settings". Make sure it's allowed to post to your Facebook wall and make sure the visibility of those posts are set to something that friends can see.

I just installed the app to see what it looked like and it should all be there by default.

If you installed it a while ago you might want to remove the app and then reauthorize the app by connecting your facebook account through Rdio's settings interface.

Leaving the application removed from Facebook and removing Facebook from Rdio Settings for a few hours did the trick. This isn't a definitive solution as it's like saying "Turn your device for a while or power-cycle your router to resolve problems"

  • I hijacked because the issue isn't really solved by the reauth process, so I decided to leave it off for a few hours then try again. And it worked, not technically sound but I think it will do. I know another user with the problem so I'm going to see if it works for them but for me the information now in this answer is complete :)
    – phwd
    Mar 14, 2012 at 4:48
  • I've noticed this solution with other facebook apps also. This is why I suggested it. one example is pinterest's facebook app. they did a major upgrade to the app after I first installed it and the changes never worked because new authorizations were required. Uninstalling from both sides (and clearing my cache) was the only way to get it working again. Mar 14, 2012 at 4:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.