When generating a screenshot using FogBugz Screenshot tool, I get the following error:

enter image description here

This used to open in a new browser window, whereas now it opens in the login window and generates the error displayed.

If I close these windows and attempt to make a second screenshot, then this works fine, and continues to work fine until I next reboot my computer and try again.

Why is this happening, and is there anything I can do to prevent it?

UPDATE: I've also tested this in BugShooting, and I get the same error when sending to FogBuz. Which suggests to me that it is the FogBugz web application which is the problem.

Why is this?


We've made a number of bug fixes to the screenshot tool in the past few months (I'm one of the developers on the FogBug team).

The screenshot you posted makes it look like you're using FogBugz On Demand. If this is the case, getting the latest version of the screenshot tool should be pretty straightforward:

  1. Uninstall your current copy of the tool
  2. Log into FogBugz
  3. Open the Extras menu and select "Capture Screenshots"
  4. Download the appropriate version of the screenshot tool for your computer and install.

The most recent version of the screenshot tool now uses your default browser to interact with FogBugz and shouldn't exhibit the error you reported.

  • Thanks for your post @Dane. I've upgraded the screenshot tool, but I'll have to wait until my next reboot before I can test it. The funny thing is, this would also happen with the first use of other screenshot tools that interact with FogBugz, such as BugShooting. Therefore it seems to me, it would be the actual FogBugz web application which is the issue?
    – Curtis
    Mar 30 '12 at 8:23
  • @Curt It all depends on how the screenshot tool interacts with FogBugz. The older version of the FogBugz screenshot tool used an Internet Explorer web control to interact with FogBugz which was prone to a number of different problems. If other tools interacted the same way, they would be susceptible to the same problems. Hope the newer version works more smoothly for you!
    – Dane B
    Mar 31 '12 at 17:20
  • Sweet! This has fixed it! Cheers
    – Curtis
    Apr 2 '12 at 12:19

I think the problem is not so much with the FogBugz Screenshot tool, but more to do with the FogBugz website. Perhaps URL values/params have changed, or maybe it is just a valid bug in the system.

There are other tools that integrate with FogBugz screenshots, for example this one, which I think if you test will probably give you the same problem. If so, this would indicate that the problem is on the website side of things as opposed to the client tool.

  • This is true, I just updated my question regarding this. How can I get around this issue? What could be the issue on FogBugz?
    – Curtis
    Mar 29 '12 at 10:53
  • @Curt: It is a tricky one, because if the bug is on the FB website you are not going to be able to fix it even if you do debug the problem. And as you have posted to them in the past with no response they might not be so inclined to do anything. One thing that is interesting though, is that the paid software I link doesn't seen to report any bugs on the issue, so perhaps this is something specific to your FB account/client machine.
    – musefan
    Mar 29 '12 at 11:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.