If I copy text with a line break in it, like this:

1st line
2nd line

and then paste in into a Google Sheets cell, then it pastes '2nd line' into the cell below.

What are the ways to avoid this?


Based on http://productforums.google.com/forum/#!category-topic/docs/formatting/-uEh3jguVu0 you can " copy the info single cell by single cell and paste the information in edit mode of the receiving cell; i,e. double-click the cell first before you paste the single cell contents". Though this is hardly 'easy' so there may be a better answer out there...


Select the cell you wish to paste into, then press F2 and it will allow you to paste the text in without separating the line breaks into their own cells.


You can quote the multiple-line contents with " now.

The quotation makes the pasting of a list of multiple-line contents so easy.

  • 1
    And what if the data already contains quotes? This is ridiculous. The cell contents should be preserved with line breaks. It is simply incorrectly functioning. Google Sheets is assuming some kind of text/CSV format for pasted cells, when in reality it should be honoring the source format. This also poses a problem for copying/pasting cells that are supposed to have quotes around them... Google Sheets unexpectedly strips off the quotes. It's absolutely incorrectly functioning and it needs fixed as of Apr 10, 2015. – Triynko Apr 10 '15 at 19:34
  • thanks! works perfect when pasting some csv(tabbed) lines with multi-line text in one column – Ivan Ferrer Villa Sep 10 '15 at 17:06

An alternative to double clicking / pressing F2 on a cell is to paste the text into the formula window (next to "fx" above the sheet).

Note that neither this nor other methods described will preserve formatting (font color, font face, etc), which may or may not be a plus.


This drove me crazy until I accidentally got my list to paste properly.

You have to double or triple click in the target cell so that the cursor appears. Then you can paste a list with line breaks into a cell in a Google spreadsheet.

I realize this was asked a year ago but my first search brought me to this post so I thought I'd share.

  • 4
    Isn't this essentially what the other answer says? – ale Jun 4 '13 at 19:02

Update as of January 2016: Right click and Paste Special > Paste Values Only. Bam!

  • 1
    This may only be for the "new" Google Sheets. I don't know if everyone is fully migrated over. – ale Jan 12 '16 at 19:44
  • 1
    This makes that each line be pasted in a new rows, not in the same cell. – Rubén Jan 12 '16 at 20:12
  • This is exactly what I was looking for and expecting (put each line in new cell). – lenooh Jun 5 '19 at 13:33

I have managed to "solve" this. Pasting line by line is not the solution of course.

The problem was the browser in my case, my friend who was using Mozilla had this problem. I was using Google Chrome and it worked fine for me. After he tried on Google Chrome, it worked for him too.

  • How is this answer to the question? – serenesat Jan 28 '16 at 15:46
  • @serenesat: It's not uncommon for a web app to have a slightly different behavior depending on browser and even OS. The vagaries of having browsers with different interpretations of standards and non-standard features. For those with easy access to multiple browsers, this seems like a viable solution to me. – ale Jan 28 '16 at 17:11
  • @AlE.: Thanks for details. – serenesat Jan 28 '16 at 17:19

I faced this same problem today, and I used the contextual option of 'Paste Format' and it worked perfectly for me!

  • Paste format does not paste content. – Rubén Jan 12 '16 at 20:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.